Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование объемов материалов с одинаковыми названиями и перенос суммы в другую таблицу
 
Прошу помощи! Хочу заполнять Отчет о расходе материалов в строительстве форма М-29 при помощи формул.
В форме два раздела: Первый раздел – объемы выполненных работ и нормативная потребность в стройматериалах, материалы могут повторяться (будет несколько строк с одинаковым наименованием материалов). во второй таблице нужно сложить количество материалов с одинаковыми наименованиями.
Это нужно делать ежемесячно.Спасибо!
 
larisaal,Почитайте про функцию =СУММЕСЛИ()
 
Да, =СУММЕСЛИ()
 
Такая формула получилась. Но результат "0"
Код
=СУММЕСЛИ('раздел 1'!B24:B27;"Бетон";'раздел 1'!J24:J27)

Где-то ошиблась.
 
У вас в таблице не "Бетон", а "Бетон " (пробел в конце). Для программы - это разные вещи. Либо пробелы убирайте, либо условия задавайте также, как написано наименование в исходной таблице (включая пробелы).
Кому решение нужно - тот пример и рисует.
 
Спасибо! Получилось.
Еще хочу упростить работу: как скопировать формулы в другие месяцы без большой доработки?
- диапазон В24:В27 постоянен для всех месяцев
- диапазон J24:J27 разный для каждого месяца.
 
диапазон В24:В27 задать через абсолютную адресацию $В$24:$В$27
Кому решение нужно - тот пример и рисует.
 
Чтобы не было накладок с названиями материалов, можно использовать Списко из Данные - Проверка данных...
 
Раздел 1 : если добавить доп. столбец с номером работы, то можно формулу для подсчета месячных объемов сделать универсальной
Изменено: Михаил Лебедев - 26 Дек 2016 18:34:19 (Заменил файл)
 
Спасибо большое!
Пока все понятно. Завтра буду пробовать на работе.
Как пойдет, напишу.
 
Здравствуйте! Снова про своё! Мне очень подошли и помогли формулы, спасибо!
Прошу помощи опять и по той же форме М-29!
В разделе 1 хочу как-то автоматизировать задание формул.
Желтым выделены объемы выполненных работ по месяцам. Нужно рассчитать объемы материалов по формулам для каждой расценки  в каждом месяце.
Если набивать в каждой ячейке можно с ума сойти. Знатоки помогите!!!
 
larisaal, в правилах сказано: один вопрос - одна тема.
Названия темам нужно давать определяющие, по проблеме. Эта тема переименована
 
Цитата
larisaal написал:
Нужно рассчитать объемы материалов по формулам для каждой расценки...
Вы мой ответ читали в #9 ? ▼
Цитата
Михаил Лебедев написал:
если добавить доп. столбец с номером работы, то можно формулу для подсчета месячных объемов сделать универсальной
...или Вы не про это спросили?
Страницы: 1
Читают тему (гостей: 1)