Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Посчет оборот/менеджер в зависимости от кол-ва человек в смене
 
Здравствуйте.
Требуется вычислить оборот по каждому менеджеру за все дни в зависимости от кол-ва работающих менеджеров в смене. Если и в B и в C стоят менеджеры, то A/2
 
на скорую только с доп столбцом
 
Да, забыл сказать, что с доп. столбцом у меня тоже получилось...
 
если Vik_tor, понял вашу задумку то вот решение без допов
Код
=СУММПРОИЗВ(($A$2:$A$10/(($B$2:$B$10<>"")+($C$2:$C$10<>"")))*(($B$2:$B$10=E2)+($C$2:$C$10=E2)))
Лень двигатель прогресса, доказано!!!
 
или
 
=СУММПРОИЗВ($A$2:$A$10/МУМНОЖ(Ч($B$2:$C$10<>"");{1:1})*МУМНОЖ(Ч(E2=$B$2:$C$10);{1:1}))
« Скажи мне так, чтоб я тебя увидел »
 
Сергей, ваша формула работает! Спасибо.
Владимир, а по вашей почему то ругается...
 
Сейчас применил на незаконченный месяц, т.е. оборот не по всем дням заполнен и есть места, где ни одного менеджера не указано, соответственно выдает ошибку НЕЛЬЗЯ ДЕЛИТЬ НА НОЛЬ.
 
массивная
Код
=СУММ(ЕСЛИОШИБКА($A$2:$A$11/(($B$2:$B$11<>"")+($C$2:$C$11<>""));0)*(($B$2:$B$11=E2)+($C$2:$C$11=E2)))
Лень двигатель прогресса, доказано!!!
 
Сергей, Сапсибо! Все работает!
Страницы: 1
Читают тему (гостей: 1)