Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вставка пустой строчки после заполненной
 
Добрый день! Подскажите, как вставить пустую строку после каждой заполненной?

Спасибо.
 
stalker138013, выделяете каждую строку с зажатым Ctrl, потом по ним правой кнопкой, и "Вставить".
Снимок.PNG (67.97 КБ)
 
=ИНДЕКС($A$2:$C$6;ЕСЛИ(ОСТАТ(СТРОКА()-1;2)=1;ОКРВВЕРХ((СТРОКА()-7)/2;1);СЧЁТЗ(A:A));СТОЛБЕЦ()-5)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Код
Sub InsertRow()
Dim lstr&, i&
lstr = Cells(Rows.Count, 1).End(xlUp).Row
For i = lstr To 3 Step -1
    Cells(i, 1).EntireRow.Insert xlDown
Next
End Sub
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Простой вариант с выделением строк с зажатым CTRL. Но у нас в прайсе около 1000 строк. Может есть способ выделить строки по-другому, а не "тыкать" на каждую??? Было бы просто бомба!!!!!!
 
А вариант Владимира почему не устраивает?
 
Вариант Владимира это Макрос?
 
Я просто не знаю куда ЭТО вставить. Поясните как для чайника подробнее? Спасибо.
 
Для этого нужно приложить хоть какие-то усилия. За Вас всё сделают в платном разделе, а здесь сами читайте -
http://www.planetaexcel.ru/techniques/3/59/
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
Страницы: 1
Читают тему (гостей: 1)