Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Функция ВПР. "Плавающая" ошибка #Н/Д
 
Использую ВПР.    
 
Все довольно просто и до определенного времени работало без ошибок, на днях столкнулся с проблемой что в некоторых ячейках появляется #Н/Д - якобы не находит среди искомой таблицы значение. Хотя при проверке (поиске вручную): Ctrl+F на таблице по которой функция производит поиск, значение присутствует и находится.    
 
По не известным причинам появляется ошибка, там где по идее не должна. Т.к. значение искомое все же есть в таблице "База" в которой происходит поиск.    
 
На всякий случай проверил в ОпенОфис - результат тот же. В недоумении.    
Формат ячеек одинаковый.  
 
Помогите пожалуйста!  
Заранее благодарю.  
<EM><STRONG>Файл удален</STRONG> - велик размер - [<STRONG>МОДЕРАТОРЫ</STRONG>]</EM>
 
Измените формулу на такую  
=ВПР(A3&"";База!A2:U3333;21;ЛОЖЬ)  
У вас разные форматы значений - в базе число как текст, в импорте - число (это видно, посмотрев форматы. Там где текст - везде одинаково, где число - разные.)
post_268084.gif (79.87 КБ)
 
{quote}{login=Duke®}{date=16.10.2011 02:08}{thema=Функция ВПР. "Плавающая" ошибка #Н/Д}{post}  
Файл удален - велик размер - [МОДЕРАТОРЫ]
{/post}{/quote}Каюсь, на размер не глянул. Обычно в этих случаях не отвечаю.
 
Ваше решение частично подошло, теперь #Н/Д стало меньше. но все же  - иногджа еще встречается.    
Прошу прощения, удалил лишние строки.    
Оставил "проблемные" и некоторые нормальные.    
 
Совпадающие при ручном поиске, но не "срабатывающие" при ВПР - подсветил желтым цветом на листе "База"
 
Ночная невнимательность - диапазоны поиска нужно закреплять:  
=ВПР(A3&"";База!$A$2:$U$3333;21;ЛОЖЬ)
 
Огромное спасибо!  
Теперь все работает. Проверил на всей книге (2.5к строк)  
ООчень благодарен.    
Теперь наконец пойду спать со спокойствием)
 
Первый раз обращаюсь к данной функции и ничего не получается, помогите пожалуйста
 
=ВПР(A8;'60'!$A$7:$B$245;2;0)  
=ЕСЛИ(ЕНД(ВПР(A8;'60'!$A$7:$B$245;2;0));"";ВПР(A8;'60'!$A$7:$B$245;2;0))  
=ЕСЛИОШИБКА(ВПР(A8;'60'!$A$7:$B$245;2;0);"")
 
Serge 007, спасибо, все получилось
 
Здравствуйте.Не работает впр,возможно дело в форматах.Требуется заполнить цены в колонку.Не посмотрите?  
<EM><STRONG>Файл удален</STRONG> - велик размер - 787К  [<STRONG>МОДЕРАТОРЫ</STRONG>]</EM>
 
Сильно извиняюсь.Вот http://rusfolder.com/33782887
 
Действительно, дело в форматах.  
Хоть он у Вас в обоих массивах, судя по ячейкам, общий, но в столбец А заводился, как текст, и не смотря, на то, что формат ячейки был изменён, он всё равно хранит текстовое значение.  
я думаю нye;жно
 
Заметьте что он нашел код в котором были и цифры и буквы(11,7),а просто цифры он не ищет
 
Обратите внимание на зелёный треугольничик в левом верхнем углу ячейки. Все числобуквенные выражения у Вас сохранены одинаково, как общий формат. А вот числовые значения в столбце А лежат как текст, а в столбце D как выражение в формате "Общий".
Страницы: 1
Читают тему (гостей: 1)
Наверх