Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск куска текста в ячейке
 
Подскажите пожалуйста правильную формулу... Мне надо чтобы в ячейке B38 формула проверала наличие текста "AN85A" и в случае истины, то значение ячейки - 10; "AN185" - 5. ИНАЧЕ во всех других случаях - 6.67.  
Я сделал эту формулу, но она работает некорректно...  
ЕСЛИ(ЕОШИБКА(ПОИСК("AN85A ";B38;1));10;ЕСЛИ(ЕОШИБКА(ПОИСК("AN185A";B38;1));5;6.67))
azat
 
Вот так будет правильно: =ЕСЛИ(ЕОШИБКА(ПОИСК("AN85A";A1));ЕСЛИ(ЕОШИБКА(ПОИСК("AN185A";A1));6.67;5);10)  
С уважением, Александр.
 
А с учетом того, что функция ПОИСК("AN85A";A1) при отрицательном результате выдает #ЗНАЧ!, то можно покороче: =ЕСЛИ(ЕОШ(ПОИСК("AN85A";A1));ЕСЛИ(ЕОШ(ПОИСК("AN185A";A1));6.67;5);10)  
С уважением, Александр.
 
{quote}{login=Sh_Alex}{date=23.09.2009 01:38}{thema=}{post}А с учетом того, что функция ПОИСК("AN85A";A1) при отрицательном результате выдает #ЗНАЧ!, то можно покороче: =ЕСЛИ(ЕОШ(ПОИСК("AN85A";A1));ЕСЛИ(ЕОШ(ПОИСК("AN185A";A1));6.67;5);10)  
С уважением, Александр.{/post}{/quote}  
Отлично. Все заработало. Только вместо A1 надо B38)
azat
Страницы: 1
Читают тему (гостей: 1)
Наверх