Страницы: 1
RSS
Сумма уникальных значений по параметру
 
Exel2016, VBA нет. Есть столбец В с определенными значениями. Нужно из него выбрать уникальные, не повторяющиеся значения и сложить. Это сделано.
А вот вторая часть не получается: сложить только те уникальные значения которые удовлетворяют условию в столбце А. Ну то есть сложить в зависимости от месяца. Функции СУММУНИК нет.
Изменено: alexey320 - 20.06.2024 09:12:21
 
Здравствуйте
Цитата
СУММУНИК
А  САМУМНИК есть? )
Например так:  { }
=СУММ(B1:B36*(A1:A36=E3)*(ПОИСКПОЗ(A1:A36&B1:B36;A1:A36&B1:B36;)=СТРОКА(A1:A36)))
"на вырост":
=СУММ(УНИК(ФИЛЬТР(B1:B36;A1:A36=E3)))
 
Спасибо большое.

А почему не прокатило через суммеслимн можете пояснить? Заранее спасибо.

А  САМУМНИК есть? ) - нет.
 
Цитата
почему не прокатило через суммеслимн
потому что подобные функции работают с диапазоном , а диапазон это еще не массив
СУММЕСЛИМН(диапазон_суммирования; диапазон_условия1; условие1; [диапазон_условия2; условие2]; …)
но стоит вам с диапазоном сделать какую-нибудь операцию - он станет массивом
 
Спасибо
 
=СУММ(B1:B36*(A1:A36=E3)*(ПОИСКПОЗ(A1:A36&B1:B36;A1:A36&B1:B36;)=СТРОКА(A1:A36)))

С этой формулой ещё один момент остался в "темноте" (не бейте больно!) часть формулы (поискпоз(...)=строка(...)) выдает результат начиная с позиции 1.
Как только вставляешь сверху (команда "вставить") 1, 2 и тд строк (или переносишь её в другую таблицу), то в самой формуле номера ячеек соответственно меняются (А1 меняется на А2 и тд) но результат все равно выдается начиная с позиции 1. В результате конечный ответ вместо значения выдает "0".
 
Замените "=СТРОКА(A1:A36)" на "=СТРОКА(1:36)-СТРОКА(1:1)+1".
 
О! Спасибо!
Страницы: 1
Наверх