Страницы: 1
RSS
Данные из диапазона по условию
 
Добрый день.

Помогите решить.

Условно сотрудник получает балы за выполнения плана, есть норма смен в месяце и если сотрудник отработал все - то все просто:
Количество балов=какому-то бонусу.

но если сотрудник отработал 5 смен из 9 например, то нужно применять другой диапазон в таблице "Балы"

в столбце Е написал как должно получится.
Экономьте электричество!
Отключите NumLock!
 
НормаСменБалов
Вася9333333,0
Петя9531111,0
Коля9432222,0
хммм....  8-0  а по какому принципу идет распределение баллов и (я так понял) бонусов ??
 
Цитата
написал:
НормаСменБалов Вася9333333,0Петя9531111,0Коля9432222,0хммм....    а по какому принципу идет распределение баллов и (я так понял) бонусов ??
начисление балов в другом месте происходит)
распределение бонусов на примере Васи.
Изменено: Scarinta - 20.06.2024 14:39:31
Экономьте электричество!
Отключите NumLock!
 
Цитата
написал:
На примере Васи)
чувствую себя как тот доцент  8-0  8-0

Есть у нас грузин, студент, по фамилии Горидзе, а зовут его Авас, и доцент Петяев, страшно тупой. Вызывает доцент этого грузина к доске и спрашивает:
- Как ваша фамилия?
- Горидзе.
- А зовут вас как?
- Авас.
- Меня Николай Степанович, а вас?
- Авас.
- Меня Николай Степанович, а вас?
........
 
Цитата
написал:
чувствую себя как тот доцент  
попробуем так)

бонусов можно получить как +10000 так и придется отдать -10000
если отрабатываешь все доступные смены (9), то чтобы выйти из минуса нужно набрать 4,5 бала.
если отрабатываешь 3 смены (Вася), то что бы выйти из минуса надо набрать 1,5 бала.
за смену можно получить 0; 0,5; 1.
Т.е. за 3 смены максимально можно получить 3 бала.

если не понятно, давайте наводящими вопросами)
Экономьте электричество!
Отключите NumLock!
 
Цитата
написал:
начисление балов в другом месте происходит)
Цитата
написал:
если отрабатываешь 3 смены (Вася),
ага, начинает проясняться имя студента...;)
т.е. надо просто найти значение по сменам/баллам, да?
ок... но сначала открой свой присланный файл и тыкни меня носом в матрицу смен/баллов как на картинке...
Изменено: BodkhiSatva - 20.06.2024 15:17:47
 
Цитата
написал:
ок... но сначала открой свой присланный файл и тыкни меня носом в матрицу смен/баллов как на картинке...
в файле нету.
была надежда, что можно математическими формулами или не использовать кучу раз если+впр)

вот файл с табличкой такой
Экономьте электричество!
Отключите NumLock!
 
День добрый
Цитата
Capture.PNG (11.87 КБ)
Чудны ваши тернистые пути )
Цитата
Данные из диапазона по условию
=ИНДЕКС(K$11:K$29;ПОИСКПОЗ(D2;J$11:J$29;)+C2-9)
Цитата
надежда, что можно математическими формулами
=10000*(D2*2-C2)/9
8)  
 
Цитата
написал:
=10000*(D2*2-C2)/9
я был близок к этому, но что то шло не так  :D  
Экономьте электричество!
Отключите NumLock!
 
офф...
Цитата
написал:
=ИНДЕКС(K$11:K$29;ПОИСКПОЗ(D2;J$11:J$29;)+C2-9)Цитатанадежда, что можно математическими формулами=10000*(D2*2-C2)/9
теперь чувствую себя просто тупым...  8)  8-0  :evil:
спрашивается: нахрена я ковырял ТС, если Павел \Ʌ/, мимоходом все порешал...
все... ухожу...  нафиг...  :evil:  
 
офф
Цитата
BodkhiSatva:   чувствую себя просто...
спрашивается: нахрена я ковырял ТС, если Павел \Ʌ/, мимоходом все порешал...
Извините, не подумал что это вас заденет, потом я иной раз, поверьте,  испытываю сходные чувства когда не вижу очевидное решение  ;)
И "ковыряли" вы его не зря - именно картинка прояснила (правда не сразу)
Цитата
все... ухожу...  нафиг..
нее - не уйдёт  ))  
Страницы: 1
Наверх