Страницы: 1
RSS
Сумма определенных ячеек в столбце
 
Доброго вечера Всем. Подскажите пожалуйста как суммировать каждую вторую или третью ячейку в столбце так чтоб если в других ячейках написан текст то чтоб он его игнорировал а то он у меня пишет #ЗНАЧ. Вот формула  
 =СУММПРОИЗВ((ОСТАТ(СТРОКА(B1:B40);2)=0)*(B1:B40)))
С уважением Тиго.
 
СУММ() игнорирует текст  
Вводим с одновременным нажатием Ctrl+Shift+Enter  
 
=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(B7:B40);2)=0;(B7:B40);0))
 
Спасибо Игорь за помощь. Но возник второй вопрос после того как входиш в строку функция то фигурные скобки теряются я как понял они и игнорируют текст и сразу получается сбой столбец не просчитывается и в ячейке показывает "0" или же если нужно поменять диапазон
С уважением Тиго.
 
формулу массива нужно вводить как формулу массива всегда.
 
Спасибо
С уважением Тиго.
 
Заранее выражаю благодарность всем создателям и авторам сообщений!  
Собственно вопрос, как определить сколько человек встречаются в таблице через каждые 3 ячейки?
 
как то так:  
=СУММПРОИЗВ(НЕ(ОСТАТ(СТРОКА($B$2:$B$22)-1;3))*($B$2:$B$22=E2))
Редко но метко ...
 
Посчитать - да, можно формулой, а вывести имена - проще с UDF:
 
Спасибо еще раз! Очень помогаете!  
Вопрос такой еще, а если такие таблицы расположены на нескольких листах, можно ли это учесть всё в одной ячейке? :)
 
Теперь можно вводить несколько диапазонов:
 
C UDF чтото не получается    
Можно ли попробовать какие-нибудь Excel формулы ?!
 
Вам формулы показали. Тоже не получается?
 
{quote}{login=vikttur}{date=27.10.2011 11:26}{thema=}{post}Вам формулы показали. Тоже не получается?{/post}{/quote}  
У меня не получается UDF формула    
Показанная формула работает только на одном листе а у меня несколько листов    
Сам пробую у меня не получается
 
Раз не получается в этом, может мне кто поможет в этом!?  
Вот формула с повторяющимся циклом у меня не как не получается её укоротить    
Пример =суммпроизвд((...)*(...+('3'!$D$20:$D$94=I5)+('4'!$D$20:$D$94=I5)+('5'!$D$20:$D$94=I5)+...))  
Учитывая что листов у меня много формула длинновата выходит, там меняются только листы.
 
> У меня не получается UDF формула  
Показанная формула работает только на одном листе а у меня несколько листов    
 
Покажите пример, на котором не получается.
 
{quote}{login=Казанский}{date=28.10.2011 01:15}{thema=}{post}> У меня не получается UDF формула  
Показанная формула работает только на одном листе а у меня несколько листов    
 
Покажите пример, на котором не получается.{/post}{/quote}  
Ваша формула удаляет значения которые не находятся в искомом диапазоне (они не должны удалятся) + повторюсь листов не мало, тогда надо прописывать все диапозоны в UDF ?
 
Формула ничего не удаляет. 26.10.2011, 08:37 Вас она, как я понял, устроила, за исключением возможности брать диапазоны с нескольких листов.  
 
Давайте пример, и что нужно получить.
 
А, Вам нужен один и тот же диапазон на нескольких листах?  
Листы идут подряд, или будете указывать список листов?
 
Диапазон один и тот же, листа идут по порядку 1,2,3    
Но раз уж вопрос на эту тему, я думаю будет интересно увидеть различные вариации,(различные диапазоны, листы содержащие текст)  
Как вариант из чего должна состоять формула: диапазон x, лист x+n1, диапазон y, лист y+n2, n кол-во(имя) листов для диапазона, искомое значение  
Извини если непонятно написано))  
P.S. в файле в конце "итого"
 
я так понимаю решение этого вопроса всё таки будет!!?
Страницы: 1
Читают тему (гостей: 1)
Наверх