Страницы: 1
RSS
Подсчет кол-ва заполненных строк
 
Как-то скучно без вас было сутки))  
 
Скажите, как можно заставить эксель подсчитать кол-во заполненных строк (текст) и выдать (цифрой) результат?  
 
Например:  
Банан  
Киви  
Апельсин  
__________  
3
 
{quote}{login=axi}{date=26.01.2010 08:13}{thema=Подсчет кол-ва заполненных строк}{post}... Скажите, как можно заставить эксель подсчитать кол-во заполненных строк (текст) и выдать (цифрой) результат?..{/post}{/quote}  
Учим: 1) - "=СЧЁТ..." в вариациях; 2) - "=пром...итоги" в вариациях; 3) осваиваем грамотную постановку вопроса/ов: заполненных строк или ячеек?.. ячеек в записях/строках или в полях/столбах?.. Как быть, если в "пустой" ячейке есть пробел?..  
Z.
 
Левой кнопочкой на значке суммы и выбрать -"Число"
 
{quote}{login=}{date=26.01.2010 08:46}{thema=Re: Подсчет кол-ва заполненных строк}{post}Учим: 1) - "=СЧЁТ..." в вариациях; 2) - "=пром...итоги" в вариациях; 3) осваиваем грамотную постановку вопроса/ов...{/post}{/quote}  
Спасибо! Все получилось - вот что значит хорошо намекнуть))
 
Ничего не получается((( я чайник. Можно более подробно?
 
то есть:  
имею таблицу содержащую цифровые значения и текст. Нужно подсчитать количество заполненных ячеек в столбце.    
 
Например:  
Банан  
12  
0  
Киви  
 
0,9  
Апельсин  
-2  
__________  
7  
 
 
Пожалуйста, не воспримите за аптоп...
 
vsim, подсказываю: рисуете таблицу с исходными данными. На втором листе показываете - ЧТО и КАК должно получиться. Затем файл (небольшой) показываете здесь. Неплохо ещё прочитать Правила.
 
Юрий М, данные с прибора выводятся в excel (лист 1) Разработчики ПО заложили как цифры так и текст. Мне нужно чтобы, заполненные поля считались автоматически (лист 2 - отмечено красным цветом). Данных очень много. И нужно учитывать как цифру так и текст.  
Ранее были "намеки", но я чайник в excel, поэтому само-собой ничего не понял.
 
Для столбца А  
=СЧЁТЗ(A1:A8)
 
А как сделать, чтоб считались только положительные занчения?
planetaexcel - respect
 
А как Вы себе представляет текстовое значение отрицательным? Если разговор только про числа, то используйте =СЧЁТЕСЛИ(A1:A8;">0")
 
Юрий М, БОЛЬШУЩЕЕ СПАСИБО!!!
 
А как посчитать, все значения больше 0?
 
Поднимите глазки на сообщение 19.04.2010, 14:26
 
в продолжении темы  
как поступить если фильтром убрали несколько строк
 
Почитать о функции ПРОМЕЖУТОЧНЫЕ.ИТОГИ()
 
Спасибо огромное
Страницы: 1
Читают тему (гостей: 1)
Наверх