Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск уникальных значений по двум столбцам
 
Здравствуйте. Подскажите(в поиске не нашел) как сделать выборку уникальных значений по двум столбцам.Нужен способ формулой.спасибо.
 
так?
 
альтернативное решение:  
 
в яч. C1 формула  
=СЦЕПИТЬ(A1;B1)  
и растянуть до конца списка  
 
в яч. D1 формула  
=ЕСЛИ(СУММПРОИЗВ(--($C$1:C1=C1))>1;"";1)  
и растянуть до конца списка  
 
проставятся единички напротив "уникальных" сочетаний, потом остается просто поставить фильтр по "1" :)
 
Еще одна альтернатива, облегченная.
 
2MCH:Спасибо,то что нужно было.
 
{quote}{login=MCH}{date=28.03.2011 10:26}{thema=}{post}так?{/post}{/quote}  
Скажите, а Вы можете как-то прокомментировать, как эта формула работает? А то я пытался разобраться, а не смог.
 
Вариант - расширенный фильтр, см. скрин.  
-13932-
post_213542.jpg (99.04 КБ)
 
а вот еще пример. как разбить одну таблицу на несколько столбцов по опред. критериям(опять же нужны только уникальные значения)? спасибо.
 
rush70, Вам предложили несколько решений, вы проглотили и не... удосужились ответить по предложенным решениям.  
 
Дальше решать неинтересно.
 
Прошу прощения, упустил из виду ответ для МСН.  
В новой задаче хотите только уникальные, но под все значения выделено по 7 строк. Так надо?
 
первая таблица(исходник) может изменяться. во второй необходимо напротив фиксированного левого столбца проставить уникальные значения из правого(строки в ней с запасом для добавления новых элементов из исходника).
 
{quote}{login=rush70}{date=31.03.2011 01:04}{thema=}{post}первая таблица(исходник) может изменяться. во второй необходимо напротив фиксированного левого столбца проставить уникальные значения из правого(строки в ней с запасом для добавления новых элементов из исходника).{/post}{/quote}  
Очередной монстр
 
забыл приложить :)
 
2MCH: Благодарю!, действительно монстр,не могли бы пояснить что вычесляет вот это СУММ(--(ПОИСКПОЗ(ЕСЛИ($A$1:$A$17=A22;$B$1:$B$17);ЕСЛИ($A$1:$A$17=A22;$B$1:$B$17);), не понятно в частности вот это "--" в функции сумм.
 
to rush70  
 
для расширения кругозора почитайте P.S. в статье http://www.planetaexcel.ru/tip.php?aid=94 и комментарии к ней. интересная штука это "--".
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
Страницы: 1
Читают тему (гостей: 1)
Наверх