Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск текста из ячейки в другом столбце
 
Итак, постараюсь по порядку.  
 
Документ Excel 2007. В столбце "А" есть список организаций, например от "А2" до "A100". А в столбце "B" есть второй список организаций, но при одинаковом названии предприятий - ячейки различаются. Например: "А2" содержит "Рога и копыта", а "B52" содержит "Рога и копыта, коммерч. фирма".    
 
В результате мне необходимо узнать какие организации из столбца "А" присутствуют в столбце "В".  
 
Руками делать очень долго. Столбцы по 20 000 строк.  
 
Очень прошу помочь! Заранее благодарен
 
Но! Руками не очень долго нарисовать пример. Не на все 20 тыс., но на 15-20 строк. Тогда и помощи ждать придется не долго.
 
Спасибо за замечание. Вот, примерный файлик...
 
Формула для 20000 строк будет неподъемная, но пока пишут макросы...  
 
=ИНДЕКС($B$1:$B$20;МАКС(ЕСЛИ(ЕЧИСЛО(ПОИСК(ПСТР($B$1:$B$20;1;ПОИСК(",";$B$1:$B$20)-1);A2));СТРОКА($1:$20))))  
 
Как вводить формулу массива:  
После введения формулы в ячейку, ввод завершается нажатием не просто Enter, а Ctrl+Shift+Enter. Формула при этом будет заключена в фигурные скобки - {}.
 
Огромное спасибо! Буду хоть кусками делать. Еще раз премного благодарен!!!
 
Да не спешите! Макросом быстрее и загрузки меньше.  
 
Хотя, если работа разовая, можно и частями.  
Для облегчения расчетов часть формулы можно вынести в отдельный столбец:  
=ПСТР(B1;1;ПОИСК(",";B1)-1)
 
Работа как раз не разовая... Спасибо, сейчас попробую разгрузить...
Страницы: 1
Читают тему (гостей: 1)
Наверх