Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Добавить код телефона к номеру городского телефона, в ячейке где находится и городской номер, и сотовый номер
 
Ребят помогите! Подскажите..
Как добавить код города в ячейку где содержится номер города и сотовый номер через? Причем код города нужно добавить именно к городскому номеру..
 
От Вас небольшой файл-пример с исходными данными и желаемым результатом.
 
Вот. В столбце А номера телефонов. В одной ячейке и сотовый номер и городской. Необходимо из столбикс С добавить код к город номеру в столбике А и чтобы получился столбик D.. подскажите пожалуйста
 
Если длина городского номера всегда одинаковая, то формула для ячейки D3
Код
=ЕСЛИ(ПСТР(A3;7;1)=",";ПРАВСИМВ(C3;ДЛСТР(C3)-1)&A3;ПОДСТАВИТЬ(A3;" ";" "&ПРАВСИМВ(C3;ДЛСТР(C3)-1)))
 
См. вариант.
 
Цитата
Dima S написал:
Если длина городского номера всегда одинаковая, то...
А она разная ((
 
Городской номер всегда начинается на 2? В любом пустом столбце формула:
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(" "&A3;" 2";" "&-C3&2))
Протянуть формулу, выделить полученный диапазон, копировать, вставить как значения. Заменить этими данными исходные данные в столбце А
 
Цитата
Юрий М написал:
А она разная ((
Не доглядел)
Тогда так
Код
=ЕСЛИ(НАЙТИ(",";A7)<(ДЛСТР(A7)/2);ПРАВСИМВ(C7;ДЛСТР(C7)-1)&A7;ПОДСТАВИТЬ(A7;" ";" "&ПРАВСИМВ(C7;ДЛСТР(C7)-1)))

тут ограничение - если городской короче мобильного)
 
Зря старались: автор заглянул и молча ушёл.
 
Ребят привет. Это я спросонья. Посреди ночи проснулся зашел и уснул)
Спссибо большое! Крутяк ребят, а то добавлял бы я еще все вручную месяц. От души!)

Буду надеятся будет работать..
Страницы: 1
Читают тему (гостей: 1)