Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
СУММЕСЛИМН возвращает 0, Один диапазон условий, но самих условий более одного
 
Здравствуйте, уважаемые форумчане!
Думаю, вопрос Вам покажется глупым, но сам я решить его не могу.
Необходимо произвести суммирование с помощью функции СУММЕСЛИМН (пример во вложении).
Диапазон суммирования - столбец В, диапазон условия - столбец А. Условия для суммирования - Яблоко; Персик.
Пишу формулу: =СУММЕСЛИМН(B2:B9;A2:A9;A2;A2:A9;A4). Верный результат 124.
Но формула возвращает 0.
Подскажите, пожалуйста, где я ошибся в написании формулы?
 
Код
=СУММЕСЛИМН(B2:B9;A2:A9;A2)+СУММЕСЛИМН(B2:B9;A2:A9;A4)
не родилось еще в диапазоне A2:A9 такой ячейки, которая ОДНОВРЕМЕННО была бы равна и ЯБЛОКО и ПЕРСИК
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко, спасибо. Знаю про этот прием, но думал, что можно как-то всё в одну формулу записать.
Еще раз спасибо!
 
Или =SUMPRODUCT(SUMIF(A2:A9;A3:A4;B2:B9))
 
может и об этом что-то знаете?
Код
=СУММПРОИЗВ(B2:B9;(A2:A9=A2)+(A2:A9=A4))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
БМВ, Ігор Гончаренко, спасибо Вам огромное за формулы!
Страницы: 1
Читают тему (гостей: 1)