Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Ссылка на данные из строки в столбец, строки с данными на одном листе, столбцы на другом
 
Подскажите, как сделать, чтобы в столбце одной таблицы данные были ссылкой на строку в другой? Нужно именно ссылкой, а не копирование транспорированием
 
Добрый день.
Так?
Код
=ГПР(C:C;Лист1!$4:$5;2;0)
 
это?
Код
=ГПР(СТРОЧН(C4);Лист1!$B$4:$M$5;2;)

лишние пробелы и пропущенные буквы исправляйте сами.
если привести месяцы к одинаковому виду то ф-ция СТРОЧН не нужна будет.
Изменено: V - 12 Мар 2018 14:19:24
 
Нет, не совсем
Как я понял ГПР ищет на одном и на другом листе "январь" и подставляет данные. Такая привязка не нужна

Нужно, чтобы Лист!2D4 = Лист!1B5, а потом я мог растянуть и все остальные бы заполнились аналогично
 
Тогда так:
Код
=ИНДЕКС(Лист1!$B$5:$N$5;1;СТРОКА()-3)
 
Оно! Спасибо!
 
PooHkrd,Что означает "СТРОКА()-3"?
Пытаюсь сделать для других строк сделать, но выходит только первое значение.
 
Вписать в любую ячейку
=СТРОКА()-3
Протянуть по строкам. Проанализировать полученный результат.
 
Можно еще так:
Код
=ТРАНСП(Лист1!$B$5:$M$5)

Но это нужно выделять весь целевой массив сразу, и вводить как формулу массива. Подробности.
Страницы: 1
Читают тему (гостей: 1)