Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
поиск по двум критериям нескольких значений
 
есть номер участка и профессия (выделенные синим цветом), необходимо по этим двум критериям выбрать все фамилии (выделенные зеленым цветом). Спасибо
 
Формируете уникальный список участков и должностей и по нему тянете МНОГОРАЗОВЫМ ВПР примеров на сайте куча
Лень двигатель прогресса, доказано!!!
 
И вам здравствуйте.
Во-первых, куда выбрать, во-вторых, ФИО выделены у вас все (правда далеко не зеленым), в-третьих, если вы хотите отбирать по признаку цвета, то это только макрос. да, и в-четвертых, поиск - как в теме, или выбор - как в описании?
Изменено: Vik_tor - 13 Мар 2018 13:01:56
 
АлексейДанник, 1.  Чем не устраивает автофильтр?  2. Ну можете построить сводную, только или уберите пустые столбцы, или проименуйте поля или .... иначе сводная не заработает
 
Фильтр штука хорошая, но в работе участвуют очень много участков и профессий
Нашел формулу:
=ИНДЕКС(E2:E71;НАИМЕНЬШИЙ(ЕСЛИ(G2=C2:C71;СТРОКА(E2:E71)-1;"");СТРОКА()-1))
но она работает с одним значением (

пожалуйста на соседнем листе в файлике помогите создать формулу чтоб по участку (к примеру 54.22.0) и по профессии (к примеру горномонтажник подземный) выбирались все ФИО
 
Цитата
АлексейДанник написал: на соседнем листе в файлике помогите создать формулу
С соседнего листа вызывайте расширенный фильтр и ... будет вам счастье. Как вариант... ;)
Изменено: Z - 13 Мар 2018 15:25:05
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
постоянно меняются ФИО, и играться фильтром трудоемко, а так бы с помощью волшебной формулы было бы счастье )
 
АлексейДанник,
 
Огромное спасибо! )
Страницы: 1
Читают тему (гостей: 1)