Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Табель рабочего времени при суточном графике, Всю голову сломал не могу разобраться
 
Добрый день.
Не могу разобраться как автоматически заполнить диапазон ячеек имея данные заполнения
Грубо говоря мы указываем первый рабочий день число интервал сутки через трое и график заполняется часами сам.
 
без примера в файле руками
Лень двигатель прогресса, доказано!!!
 
Таблица заполнена вручную как бы это автоматизировать.
 
для данного примера в D2 и растянуть по таблице
Код
=ЕСЛИ(ОСТАТ(СТОЛБЕЦ()-3-$C2;$B2+1)=0;24;"")
Лень двигатель прогресса, доказано!!!
 
Огромное спасибо.
Если не трудно опишите функцию. Чтобы понимать.
 
прогоните формулу через вычисления на вкладке ФОРМУЛЫ есть такой инструмент ВЫЧИСЛИТЬ ФОРМУЛУ
Лень двигатель прогресса, доказано!!!
 
Посмотрел буду читать описания функций.
Еще раз спасибо теперь с восьмерками буду разбираться.
 
Подскажите пожалуйста еще одну загадку
Есть два макроса Hide и Show
если в ячейки AJ17=X то запустить макрос Hide
если в ячейки AJ17=не X или к примеру 31 то макрос Show
сделал только так
Разместил код в модуле листа

Private Sub Worksheet_Calculate()
   If [AJ17] = "X" Then Hide
   End Sub

когда в ячейке AJ17 появляется X выполняется макрос Hide
как сделать остальное не знаю если пишу еще одно условие все зависает
можно сделать чтобы проверка запускалась при изменение какой ни бутить ячейки
Изменено: vlemeshkin - 14 Мар 2018 17:19:56
Страницы: 1
Читают тему (гостей: 1)