Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнение ячеек с форматом Дата (VBA), Сравнение ячеек с форматом Дата
 
Добрый день, подскажите, пожалуйста, как работать с ячейками Даты.
Задача состоит в том, чтобы подсчитать количество объектов на Листе1 с совпадающим месяцем и годом таблицы на Листе "Итого" и вывести значения на лист Итого.
Проблема в том, что только на листе "Итого" даты в формате (месяц, год), а на листе1 (день, месяц, год). Написанная ниже программа совпадений не находит.

Лист 1
доктордатадоктордатадоктордатадоктордата
трактор14.12.2017лунапрсолнцеполлунарп
трактор10.01.2018тракторвтрактордек.17лунав
тракторрлунапрморковьполлунава
тракторвлунадлолунапголунацув
Лист Итого
дек.17янв.18
1
 

Sub Кнопка1_Щелчок()

Dim a As Integer, b As Integer, i1 As Integer, j1 As Integer, j2 As Integer

For j1 = 1 To 8

If Worksheets("Лист1").Cells(2, j1) Like "доктор" Then

For i1 = 3 To 6

If Worksheets("Лист1").Cells(i1, j1) Like "трактор" Then

For j2 = 1 To 2

If Worksheets("Лист1").Cells(i1, j1 + 1) Like Worksheets("Итого").Cells(1, j2) Then

a = Worksheets("Итого").Cells(2, j2)

a = a + 1

Worksheets("Итого").Cells(2, j2) = a

End If

Next j2

End If

Next i1

End If

Next j1

End Sub

 

 
Tanya15, приложите файл-пример с нормальными данными, а не с этим бормотанием умалишенного. Что есть - что надо получить.
 
Есть -  таблица на Листе1
Надо получить - на Листе 2 количествоКнига12.xlsx (11.06 КБ)записей к доктору Петрову в декабре 2017 и январе 2018
Изменено: Tanya15 - 14 Мар 2018 16:09:55
 
Для А3
Код
=СУММПРОИЗВ((Лист1!$A$3:$H$6="Петров")*(ТЕКСТ(Лист1!$B$3:$I$6;"МГ")=ТЕКСТ(A2;"МГ")))
Страницы: 1
Читают тему (гостей: 1)