Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти данные по строкам и вывести их соответствия
 
Приветствую.
Поставили задачку, решение которой предполагаю только в Excel.
Суть такова:

Есть столбец с текстовыми данными (адреса), к которым привязаны числовые данные в соседней правой ячейке. В таблице загружаю данные из другого источника, так же с текстовыми данными, к которым привязаны другие числовые данные. Нужно сравнить ячейки с текстом, и если они совпадают, перенести числа из второго столбца данных к первому. При не соответствии оставить поле пустым.

Подскажите, пожалуйста, формулу, которая поможет свершить сие непотребство.
 
Gortor, привет. Ну судя по описанию ВПР() должна справиться.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Осознал процесс в мозгу.. Система такая.

В столбце "А" названия улиц, в "Б" IP оборудования, в "В" нужно вставить формулу. "Д" - названия улиц, "Е" - значения

Задача в том, что бы формула брала значение "А" и проверяет его со значением "Д", причем во всем столбце. Если есть совпадение, то значение в "Е", соответствующее строке из "Д", поместить в "В", в одну строку с о значением из "А", которое бралось для сравнения. Если значение в "Е" не найдено или в "Д" нет данных, присваивать значение "0"...

Присвоение "0" не критично, могу дописать ручками. Главное найти соответствие в "Д" со значением строки в "А", скопировать значение справа от найденной строчки в "Д" и поместить его в строчку с искомым из "А" в "В"...


П.С. надеюсь объяснил понятно и правильно...
 
Цитата
Bema написал:
Ну судя по описанию ВПР() должна справиться.
Спасибо большое. Покопался в инструкциях по ВПР, создал =ВПР(A2;E:F;2;ЛОЖЬ) Вроде, работает. завтра проверю на нужной табличке.  
Страницы: 1
Читают тему (гостей: 1)