Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Перенос и группирование данных
 
Доброго дня вам всем!
не откажите в помощи.
в файле имеем несколько листов:
остатки,  акт приема.

при приеме товара на первом листе вносится номер накладной прихода.
необходимо сделать так что бы при внесении номера накладной в ячейку на листе "акт приема", в столбцы: название, срок годности и количество, переносились данные из первого листа.

необходимо что бы данные группировались по названию, сроку и количеству.
нужно это для облегчения работы завсклада, он вносит номер акта прихода и распечатывает готовый акт с перечнем товара который принял
 
заменить заголовки таблицы на листе остатки на аналогичные в акте приема.
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(остатки!$A$1:$J$9999;НАИМЕНЬШИЙ(ЕСЛИ(остатки!$B$2:$B$9999=$B$2;СТРОКА(остатки!$B$2:$B$9999));ЧСТРОК($A$6:$A6));ПОИСКПОЗ(B$5;остатки!$A$1:$J$1;0));"")
 
Огромное спасибо.

есть момент, скопировав формулу в другой файл, теряется работоспособность, в чем может быть дело? порядок столбцов и названий одинаковый
в формуле пропадает знаки - { }
Изменено: DenSV - 15 Мар 2018 10:48:31
 
формулы массива вводятся сочетанием клавиш ctrl+shft+enter
 
Да уже вспомнил, спасибо!
Страницы: 1
Читают тему (гостей: 1)