Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вычислить повторение в заданном отрезке времени по датам
 
Всем привет!
Помогите пожалуйста вычислить нарушителей )))
Некоторые люди умудряются зайти на обед дважды, а то и трижды. Каждый раз вручную смотреть муторно. Условное форматирование тоже не особо погло. Надеюсь на Ваши знания.

Спасибо заранее. Файл прикрепляю.

ПС: Если это будут полные тезки, ничего страшного, таких мы простим )))
Изменено: Бекбол Косбаев - 15 Мар 2018 12:53:17
 
Бекбол Косбаев,а как вы определили что в обед зашел дважды?? и где вход и где выход!?
Изменено: a.i.mershik - 15 Мар 2018 12:53:19
 
Н21 и Н43 Ibragimuly Isatai.
Данные по выходам не выгружал. Они иногда выходят через черный выход.
Изменено: Бекбол Косбаев - 15 Мар 2018 12:56:44
 
Бекбол Косбаев, КАК ВЫ ОПРЕДЕЛИЛИ?
 
Как? С помощью условного форматирования. Но там даты разные
 
Доброе время суток
Как-то так, можно.
 
Формула массива:
=ЕСЛИ(СУММ(--(H1=ЕСЛИ(ЦЕЛОЕ($B$1:$B$1142/1)=ЦЕЛОЕ(B1/1);ЕСЛИ($D$1:$D$1142=D1;$H$1:$H$1142))))>1;"Нарушитель";"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, формула не показала

Идея с Pivot таблицой очень интересная, но я не понял как она работает
 
В ячейке I21 и I43 указано, что Ibragimuly Isatai нарушитель.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Бекбол Косбаев написал: но я не понял как она работает
Сводная показала, что mr N 2 раза отмечен на обеде. Однако, есть масса вопросов. Разрыв по времени у mr N всего 3 минуты. Если это время ВХОДА на обед, то где время ВЫХОДА? Человек мог выйти сполоснуть руки, верно. И что можно сделать за три минуты или с разрывом в три минуты - съесть за троих шурпы и бауырсаков, хапнуть чужука?!. Не обижайтесь, но суть вашей проблемы совершенно не прорисовывается... ;)  
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
Z написал:
суть вашей проблемы совершенно не прорисовывается
Бекбол Косбаев, ещё не понятно вот это
Цитата
Бекбол Косбаев написал:
Если это будут полные тезки, ничего страшного, таких мы простим
по какому принципу Excel должен понять, тёзка ли это нарушителя или сам нарушитель? Сколько у Вас всего уникальных едоков?
 
Цитата
Z написал:
Разрыв по времени у mr N всего 3 минуты.
Я умышленно вставил человека близко, чтобы было видно. Разрывы бывают более 40 минут обычно
 
Цитата
Che79 написал:
Сколько у Вас всего уникальных едоков?
Например если есть два Дмитрия Пака, если они повторятся, пусть формула показывает что он ел два раза, но у нас таких пока что нету )))
 
Цитата
Bema написал:
В ячейке I21 и I43 указано
ух ты, а в тот раз не было, у меня скаченный файл сохранился ))) Спасибо
 
Цитата
Бекбол Косбаев написал:
ух ты, а в тот раз не было
Чудеса да и только ;) . Пожалуйста.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх