Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула. изменить формат телефона
 
Здравствуйте. Помогите пожалуйста сделать формулу чтобы преобразовать:
'+79999999999
в
(999) 999-99-99
Изменено: BobbyJo - 16 Мар 2018 00:55:58
 
=ТЕКСТ(ПРАВБ(A2;10);"(000) 000-00-00")
 
Спасибо!
 
вариант UDF в C1
 
Код
Function aaa$(text$)
  Dim text1$
With CreateObject("VBScript.RegExp"): .Pattern = "(\d{3})(\d{3})(\d{2})(\d{2})$"
  text1 = .Replace(text, "($1) $2-$3-$4"): aaa = Mid(text1, 2)
End With
End Function
Изменено: кузя1972 - 16 Мар 2018 07:09:32
 
В VBA можно и без тяжелой артиллерии
Код
Function aaa(text)
  aaa = Format(Right$(text, 10), "(@@@) @@@-@@-@@")
End Function
 
Всем спасибо!
Страницы: 1
Читают тему (гостей: 1)