Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Преобразовать диапазоны в строки/столбцы
 
Всем привет!

Подскажите, каким образом в Excel можно из диапазона вида 1900-1999 преобразовать в строку/столбец вида 1900, 1901, 1902 ... 1999.
Для одного такого диапазона можно воспользоваться транспонированием, но таких диапазонов около десятка тысяч и каждый разной длинны.

На сайте я нашел UDF:
Function Diapazon(cell As String) As StringDim iTemp As String
Dim iBegin As Integer
Dim iEnd As Integer
 iBegin = Split(cell, "-")(0)
 iEnd = Split(cell, "-")(1)
  Do
    iTemp = iTemp & CStr(iBegin) & ";"
    iBegin = iBegin + 1
  Loop While iBegin <> iEnd
    Diapazon = iTemp & iEnd
End Function

Но, он почему то не работает (либо я не умею пользоваться функциями пользователей).
 
Цитата
Артем Трофимов написал: таких диапазонов около десятка тысяч
Покажите файл-пример хотя бы с парой десятков. И желаемый результат в нем
Согласие есть продукт при полном непротивлении сторон.
 
Была мощная тема: как перечислить числа входящие в диапазон
А что у вас не так - без файла-примера поймет только телепат.
Изменено: Казанский - 16 Мар 2018 10:00:49
 
Приложил пример (в примере строчный результат, но подойдет и по столбцам).
У меня подобных диапазонов 10 тыс.
 
Вот такая формула:
=ЕСЛИ(C3>=$B3;"";$A3+СТОЛБЕЦ()-4)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
вопрос снят. вникнул в формулу. :)
Изменено: V - 16 Мар 2018 10:27:19
 
Цитата
V написал:
вопрос снят
Ну вот, а я сижу и думаю над ответом ;)  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Bema написал:
Вот такая формула:=ЕСЛИ(C3>=$B3;"";$A3+СТОЛБЕЦ()-4)

Спасибо, помог! :)  
Страницы: 1
Читают тему (гостей: 1)
Наверх