Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как вытаскивать каждую четвертую ячейку?
 
Подскажите как можно модифицировать формулу =ИНДЕКС(Лист1!A$3:T$3;1;СТРОКА()-3) , чтобы при растягивании она относилась только к каждой четвертой ячейке, т.е чтобы она вытаскивала из третьего ряда листа1 только каждое четвертое значение

Подробнее в файле
Изменено: mmsh - 16 Мар 2018 11:48:19
 
Так можно:
=ИНДЕКС($D$3:$D$23;(СТРОКА()-3)*4+4)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
А если в одной из таких ячеек тоже будет ноль, его выводить в список нужно?
 
PooHkrd,да
 
Bema, не совсем так, ему нужно из строки на листе 1 тащить значения.
mmsh, У вас в примере число 50 это третье по счету значение в строке на листе 1, а остальные идут уже на каждом 4 месте.
Изменено: PooHkrd - 16 Мар 2018 12:00:37
 
Нет, это не совсем то.
Способ Bema позволяет на листе 2 столбец d преобразовать в столбец f автоматически, а необходимо, чтобы столбец d сразу вытаскивался с листа 1 нужным видом.
Т.е. вопрос в том, как модифицировать именно формулу  =ИНДЕКС(Лист1!A$3:T$3;1;СТРОКА()-3), чтобы с листа1 вытаскивались данные каждой четвертой ячейки в строке
 
Так:
Код
=ИНДЕКС(Лист1!A$3:T$3;1;3+(СТРОКА()-3)*4)

Рекомендую оживить в памяти учебник 5 класса по алгебре, кажется там есть про арифмитические прогрессии.  ;)
Изменено: PooHkrd - 16 Мар 2018 12:06:46
 
PooHkrd, Огромное спасибо!
 
Цитата
PooHkrd написал:
Bema , не совсем так, ему нужно из строки на листе 1 тащить значения.
Ага, недоглядел.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
=ИНДЕКС($D$3:$D$31;СТРОКА(A1)*4)
и тянуть  формулу в низ.
Изменено: azma - 16 Мар 2018 12:36:45
 
Цитата
azma написал:
и тянуть  формулу в низ
потом подняться на верх , посмотреть на пример, потом #5 и  .....
Страницы: 1
Читают тему (гостей: 1)
Наверх