Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Получение значений из растущей со временем столбцами таблицы
 
Подскажите формулу для получения Итогового результата последнего месяца при выборке значений из таблицы, которая будет увеличиваться с каждым новым месяцем.
Возможно ли к ВПР приделать условие на изменение "номера столбца" ? Чтоб увеличивался каждый месяц, либо условие по сравнению дат...  Хорошо б совместить с ручным изменением необходимого месяца получать и выборку из этого месяца общей таблицы.
 
Вариант.
=ИНДЕКС($C$3:$K$9;ПОИСКПОЗ(A15;$A$3:$A$9;0);ПОИСКПОЗ($C$14;$C$2:$K$2;0))
 
=ВПР(B15;$B$3:$N$9;ПОИСКПОЗ($C$14;$B$2:$N$2;);0)
 
Спасибо, работает. ПОИСКПОЗ - хорошая штука!
Страницы: 1
Читают тему (гостей: 1)