Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск строки позиции в нескольких столбцах
 
Здравствуйте, догадываюсь, что в общем-то всё легко, но всё же хотелось узнать, потому что сам найти информацию не смог. Проблема в следующем, есть таблица с несколькими столбцами в которые записаны допустим имена. Нужна формула, которая бы возвращала номер строки конкретной позиции.
 
Так воплотите вашу догадку, раз все легко.
 
Цитата
Tiberiumses написал: есть таблица с несколькими столбцами в которые записаны допустим имена
"Допустим", "Представьте" - все это вода.
Есть Правила, а в них пп 2.2, 2.3.
ps Есть на сайте "Приемы", есть "Поиск" - посетили, включили?.. ;)
Изменено: Z - 17 Мар 2018 18:27:09
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
У меня правильно описана задача, я не совсем понимаю зачем нужно знать, что мне нужны поиск не имён, а поиск терминов в игре (если я начну описывать что и как, это превратится в очень большой пост, а разницы никакой). Версия Ексель 2013, если вы об этом. Пример я предоставил... не понимаю, что не так((( ?
Поиском пользовался, ничего на данную тему не нашёл, в примерах тоже нашёл только про поискпоз, но эта функция не работает нормально если просматриваемый массив больше одного столбца.
Нет так нет, если я нарушаю какие-то правила, придётся справляться своими силами.
 
Доброе время суток.
Цитата
Tiberiumses написал:
про поискпоз, но эта функция не работает нормально если просматриваемый массив больше одного столбца.
Собственно, а что мешает её использовать дважды или трижды, проверяя какой из результатов не вернёт ошибку? Дочитать про ЕСЛИ и ЕОШИБКА (ЕОШ) и подобные?
 
Согласен так будет работать, собственно именно так сейчас я и делаю, но если столбцов около сорока, то формула становиться "немного" растянутой
 
Цитата
Tiberiumses написал:
но если столбцов около сорока
О, вот и подробности пожаловали.
 
И вопрос даже с подробностями не изменился.
 
Увы, два столбца и много столбцов - для этих вариантов могут быть разные решения.
Если для двух столбцов обработка массивов будет излишеством ( достаточно двух комплектов ЕСЛИОШИБКА(ПОИСКПОЗ...);)), то для многих столбцов наоборот.
=СУММПРОИЗВ(($B$3:$C$11=E13)*СТРОКА($B$3:$C$11))
Только не уточняйте теперь, что возможно повторение имени...
 
Нет, всё работает. Спасибо большое! Это сильно упростит задачу.
 
Ещё две формулы
Код
=MAX(INDEX(ROW($3:$11)*($B$3:$C$11=E13);0))
Код
=IFERROR(AGGREGATE(15;6;ROW($3:$11)/($B$3:$C$11=E13)/($B$3:$C$11<>"");1);"")
 
jakim, А смысл в INDEX если просто =MAX(ROW($3:$11)*($B$3:$C$11=E13)) , ну разве что массивная.
 
Смотрите приложение.
Обе формулы не требуют массивного ввода.
Изменено: jakim - 17 Мар 2018 22:14:39
 
jakim, Вы меня не поняли. Если убрать INDEX, то достаточно массивного ввода, и все работает. Или это принципиальное мнение не использовать массивные функциию?
 
Зачем использовать формулы с массивным вводом, если можно обойтись.
 
Не всегда верно. Например, массивная, введенная для диапазона, может считать быстрее отдельных простых.
Страницы: 1
Читают тему (гостей: 1)