Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Посчитать серии повторений в столбце и вывести табличкой
 
Привет!
Есть столбец с цифрами 1 и 0. Можно ли как-нибудь по простому вывести серии повторений ячеек с 0 и серии с 1.
например
1
0
0
0
0
1
1
1

итог
по 1:
1-1 раз
2-0 раз
3-1 раз

по 0:
1-0 раз
2-0 раз
3-0 раз
4-1 раз
 
ser987, А как это у Вас в файле выглядит?

Просто наверно никак.
Изменено: БМВ - 18 Мар 2018 01:58:40
 
так и выглядит как в примере. 10000 перемешанных 1 и 0 в столбик
 
Я Вам о файле с примером намекал.
 
Посмотрел. Это то что нужно, всё отлично считает. Спасибо!!!  
 
Доп. формла для файла из сообщения №2
=ЕСЛИ(A2=A1;ЕСЛИ(ИЛИ(A2<>A3;A3="");СТРОКА()-ПРОСМОТР(2;1/($C$1:C1=-1);СТРОКА($C$1:C1))+1;);(A2<>A3)*2-1)
 
А я вот так
=IF(OR(A3<>A2;A3="");ROW()-IFERROR(LOOKUP(2;1/($A1:A$2<>A2);ROW($A1:A$2));1);"")
А если не рассчитывать что данные с первой строки или есть шапка, то
=IF(OR(A3<>A2;A3="");ROW()-LOOKUP(2;1/($A1:A$2<>A2);ROW($A1:A$2));"")
Страницы: 1
Читают тему (гостей: 1)