Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как суммировать числа из ячеек, где также имеется текст?
 
Здравствуйте. Подскажите, пожалуйста, как получить сумму чисел из ячеек, в которых также присутствует "вольный" текст.
Например:
Валя 2
Алекс 10
Света 6
получить сумму 18, соответственно. Пример.xlsx (10.93 КБ)  
 
Цитата
paLLkin написал: как получить сумму
Разогнать по столбам - текст/число - и считать... ;)
ps У вас поиск по форуму отказывается работать?
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Текст и число будут находиться в одной ячейке, разделять их не получится. Прошу прощения, что сразу это не указал
Изменено: paLLkin - 18 Мар 2018 14:10:46
 
Формула массива:
=СУММ(--ЕСЛИОШИБКА(ПРАВСИМВ(B2:AF5;ДЛСТР(B2:AF5)-ПОИСК(" ";B2:AF5));0))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
paLLkin написал:
Разогнать по столбам - текст/число - и считать
Цитата
paLLkin написал:
Текст и число будут находиться в одной ячейке, разделять их не получится
А Вы пробовали? Ведь есть специальный инструмент для этого - Текст по столбцам называется.
 
Цитата
Юрий М написал:
А Вы пробовали? Ведь есть специальный инструмент для этого - Текст по столбцам называется.
Задача как раз в том, чтобы не разбивать по столбцам.
 
еще вариант
=СУММПРОИЗВ(--ПРАВБ(0&ПОДСТАВИТЬ(B2:AF5;" ";"              ");15))
 
=СУММПРОИЗВ(--ПРАВБ(0&B2:AF5;2))

P.S. оказывается, то же самое )
 
Большое всем спасибо!
Страницы: 1
Читают тему (гостей: 1)