Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Объеденить данные из столбца с данными из строки и подставить значения на перечечение строки и столбца.
 
Добрый день!
Нужна помощь !!!
Есть прайс в котором в  первом столбце  расписаны наименования товара,  а в строке цена  в зависимости от размера, размеры  указаны в строке заголовка таблицы. Необходимо  сформировать прайс лист в три столбца: 1.Наименование+размер, 2. Изображение,  3. Цена.  
Бог кости не бросает
 
Добрый день! Помогаю - необходимы два цикла по ячейкам - один по вертикали, в нём вложенный по горизонтали. Выводите в ячейку склейку этих двух ячеек и значение на пересечении.
 
Hugo, а для тех кто в танке , можете пример сделать ?
Бог кости не бросает
 
Тремя формулами:
=ИНДЕКС($A$3:$A$23;ОКРУГЛВВЕРХ(СТРОКА(A1)/СЧЁТЗ($D$2:$AK$2);0))&"; размер - "&ИНДЕКС($D$2:$AK$2;;ОСТАТ(СТРОКА(A1)-1;34)+1)
=ИНДЕКС($B$3:$B$23;ОКРУГЛВВЕРХ(СТРОКА(A1)/СЧЁТЗ($D$2:$AK$2);0))
=ВПР(ЛЕВСИМВ(A29;ПОИСК(";";A29)-1);$A$3:$AK$23;ПОИСКПОЗ(ПСТР(A29;ПОИСК("размер - ";A29)+9;ДЛСТР(A29));$A$2:$AK$2;0);0)
Проверяйте.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
coregonus написал:
можете пример сделать ?
- могу, но никто ведь не просил... :)
Да и не нужно уже - есть решение формулами.
 
Всем спасибо!
Bema, Благодарю за пример, спасибо!
Бог кости не бросает
Страницы: 1
Читают тему (гостей: 1)