Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вычитание даты из даты - разность в днях
 
Доброго дня!

Подскажите пожалуйста как в Excel вычитать дату из даты, чтобы результат отображался в формате даты. Т.е.
ДД.ММ.ГГГГ - ДД.ММ.ГГГГ = разность в формате ДД.ММ.ГГГГ
 
iv-jul, взять и вычесть :). Каждой ячейке установить формат даты.
Если по какой-то причине это не получается, значит, одно из двух значений не дата, а, например, строка, и тогда надо её сперва привести к нужному типу данных.
 
iv-jul, Приложите файл-пример
Несколько дат и желаемый результат.
Возможно так нужно
=ТЕКСТ(РАЗНДАТ(A1;A2;"YD");"0\ \дн. ;;")&ТЕКСТ(РАЗНДАТ(A1;A2;"YM");"0\ \ме\с. ;;")&ТЕКСТ(РАЗНДАТ(A1;A2;"Y");"0\ \г.;;")
В А1 меньшая дата, а А2 - большая
Изменено: АlехМ - 19 Мар 2018 11:07:40
Алексей М.
 
Irregular Expression,
не совсем корректно обозначил задачу. Пример:
Ячейка №1: Задается значение 10.03.2018
Ячейка №2: В ней формула, в результате вычислений получается значение 20.03.2018
Результат (ячейка №3): В ней нужно получить результат в днях: Ячейка №2 - Ячейка №1 = 10 дн.

Использую функцию РАЗНДАТА(A1;А2;"d")

Файл пример прилагаю.
Изменено: iv-jul - 19 Мар 2018 11:14:59 (Корректировка. Загрузил не правильный файл)
 
iv-jul, в ячейку H6 - установить числовой формат:
Код
=F6-D6+1
или
=РАЗНДАТ(D6;F6;"d")+1
Изменено: a.i.mershik - 19 Мар 2018 11:26:00
 
a.i.mershik,
спасибо! Всё гениальное как всегда просто. Тема закрыта.
Страницы: 1
Читают тему (гостей: 1)