Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автоматическое определение % в зависимости от текущей даты и заданного срока задачи
 
Добрый день!

Прошу подсказать как победить следующую задачу: есть некий график в котором будет контроль/сравнение запланированного "% выполнения" и текущего "% выполнения". Есть диапазон дат ПЛАН и ФАКТ:
а) в диапазоне ФАКТ "% выполнения" будет задаваться вручную
б) в диапазоне ПЛАН "% выполнения" должен рассчитываться автоматически (исходя из текущей даты и заданных дат у задачи), т.е.
- планируемое начало Подзадачи №1: 01.03.2018
- планируемое завершение Подзадачи №1: 30.03.2018
- нужно чтобы каждый день (в зависимости от текущей даты) и заданного срока НАЧАЛО/КОНЕЦ указывался "% выполнения" (округление до целых чисел 0,1,2 .... 100)
Например:
- если сегодня 01.03.2018 (или меньше), то указано 0%
- если сегодня 10.03.2018, то указано 33%
- если сегодня 15.03.2018, то указано 50%
- если сегодня 20.03.2018, то указано 67%
- если сегодня 30.03.2018 (или более), то указано 100%


Файл пример во вложении.
Автоматическое определение процентов должно быть в ячейках выделенных желтым (D10-D12).
 
iv-jul, Попробуйте так:
Код
=ЕСЛИ($B$3<E10;0;ЕСЛИ($B$3>G10;100;(G10-$B$3)/(G10-E10)*100))
Нужно бежать со всех ног, чтобы только оставаться на месте, а чтобы куда-то попасть, надо бежать как минимум вдвое быстрее!
 
Dyroff,
спасибо за помощь!

Прошу извинить за критику, но результат вычислений (в основном промежуточных) получается не корректный, вот несколько примеров при использовании вашей формулы (расчет делается относительно даты 20.03.2018). См. вложение.
Снимок.PNG (21.86 КБ)
Изменено: iv-jul - 20 Мар 2018 09:36:48 (Нужно)
 
iv-jul, сейчас Вам на картинке сделают решение)
 
A.i.mershik, не сомневаюсь в "творческих подходах" по решению проблем специалистов форума, но в картинке делать ничего не нужно.

Изначальный файл загружен мной.
Файл с предложением решения проблемы загружен в ответе от Dyroff, в нем просто меняешь даты и получаешь результат "% выполнения ПЛАН" (ячейки выделены желтым цветом D10-D12).
 
iv-jul, ну допустим я не вижу даже столько подзадач в файле их там 3 а у вас на картинке 6...
 
A.i.mershik, я просто в одной подзадаче меняю сроки (начало и продолжительность). Чтобы понять, что предложенная формула справляется.
В картинке для удобства восприятия сделал несколько примеров при каких значениях не получается нужный результат.  
 
iv-jul, чуть изменил формулу...что бы когда дата сегодня будет больше даты "конец"
Код
=ЕСЛИ($B$3<=E10;0;ЕСЛИ($B$3>=G10;1;($B$3-E10+1)/F10))
Изменено: a.i.mershik - 20 Мар 2018 10:00:50
 
A.i.mershik, спасибо! Как всегда на высоте!

Тема закрыта.  
Страницы: 1
Читают тему (гостей: 1)
Наверх