Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выпадающий список из двух источников., объединение диапазонов
 
Добрый день!
Есть задача выводить выпадающий список из двух источников.
То есть имеем два диапазона, например A1:A4 и B1:B3 со значениями {А1;А2;А3;А4} и {B1;B2;B3} соответственно. Хочется сделать формулой выпадающий список без промежуточных объединений в один диапазон {А1;А2;А3;А4;В1;В2;В3}.
Кроме vba и пользовательской формулы в голову ничего не лезет.
 
likelol,  а файл пример есть? могли бы прикрепить с тем что есть и что хотелось бы получить.!?
 
a.i.mershik, приложил файлик.
 
Вариант с доп. столбцом.
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$H$11;ОСТАТ(СТРОКА()-2;10)+1;ЦЕЛОЕ((СТРОКА()-2)/10)*2+1);"")
=ЕСЛИОШИБКА(ИНДЕКС($L$2:$L$72;НАИМЕНЬШИЙ(ЕСЛИ($L$2:$L$72<>0;СТРОКА($L$2:$L$72)-1);СТРОКА()-1));"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, спасибо, но проблема как раз в том, что отдельный столбец мне не нужен, и я стараюсь от него уйти. То есть 3 столбца - это источник для выпадающего списка, а не источник для объединенного столбца.
В идеале - может есть какая функция, которая просто несколько именнованных диапазонов сможет объединить в один.
 
Цитата
likelol написал:
отдельный столбец мне не нужен
А чем плох доп. столбец? Его можно убрать на отдельный лист, диапазоны брать с запасом, а сам лист скрыть. Я не настаиваю, просто интересно понять чем мотивировано такое жесткое условие.
PS. Самому интересно увидеть решение одной формулой.
Изменено: Bema - 20 Мар 2018 13:25:59
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Может такой вариант подойдёт?
Никаких врагов, зато и никаких друзей.
 
Alemox, хороший вариант, но нужно всё объединить.

Bema, мне надо играть с комбинациями справочников в выпадающих списках. Комбинаций может быть очень много, делать под каждый список столбцы не очень удобно, да и не нужно т.к. я знаю первоначальный набор элементов.

Например, у меня есть список продуктов, закупаемых от третьих лиц и список продуктов, который мы производим. В разных случаях мне нужен выпадающий список двух наборов вместе, отдельно или вообще с добавлением технических значений типа "Null", "Не применимо" итд.
 
Ну тогда только макросы. Или именованные диапазоны с допстолбцами.
Никаких врагов, зато и никаких друзей.
Страницы: 1
Читают тему (гостей: 1)
Наверх