Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Отбор повторяющихся значений из таблицы
 
Здравствуйте! В таблице с несколькими столбцами (более двух) занесены данные, которые могут дублироваться в других столбцах. Необходимо вывести в отдельный столбец все повторяющиеся значения! Прикладываю файл с примером! Буду очень признателен, кто может помочь!
Изменено: ALEX1985 - 20 Мар 2018 10:33:15
 
ALEX1985, Добрый день, Вы бы для приличия заполнили что должно получится...
 
Вот такая фигня получилась:
=ИНДЕКС(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($A$2:$E$11;$A$2:$E$11)>1;$A$2:$E$11);СТРОКА($1:$100));НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($A$2:$E$11;$A$2:$E$11)>1;$A$2:$E$11);СТРОКА($1:$100));НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($A$2:$E$11;$A$2:$E$11)>1;$A$2:$E$11);СТРОКА($1:$100));0)=СТРОКА($1:$100);СТРОКА($1:$100));"");СТРОКА()-1))
Вводить как формулу массива.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
вариант макроса,кнопки test и очистка
Код
 Sub test()
Dim z, z1, i&, j&, m&: z = Range("A2:E" & Range("A" & Rows.Count).End(xlUp).Row).Value
ReDim z1(1 To UBound(z) * 5, 1 To 1)
    With CreateObject("scripting.dictionary"): .CompareMode = 1
    For j = 1 To UBound(z, 2)
     For i = 1 To UBound(z)
     .Item(z(i, j)) = .Item(z(i, j)) + 1
    Next i, j
   For j = 1 To UBound(z, 2)
    For i = 1 To UBound(z)
     If .Item(z(i, j)) > 1 Then: m = m + 1: z1(m, 1) = z(i, j)
    Next i, j
  unic z1
  sort
End With
End Sub
Изменено: кузя1972 - 21 Мар 2018 00:16:55
Страницы: 1
Читают тему (гостей: 1)
Наверх