Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск значения ячейки в диапазоне
 
Добрый день форумчане.

Прошу подсказать с формулой.
Имеются 2 столбца, необходимо найти значение из 2 столбца в диапазоне первого и напротив него написать это значение, Пробовал через =СУММПРОИЗВ(ДЛСТР( , но ничего не получилось, если кто сталкивался прошу помощи. Пример вкладываю.
 
=ВПР(B2&"*";A:A;1;)
неправильно, сразу не заметил
Изменено: Catboyun - 20 Мар 2018 15:15:07
 
для Ручка4 и Ручка40 будет одинаковое значение
Лень двигатель прогресса, доказано!!!
 
да, в этом то и проблема.
 
Walkish, здравствуйте!
Ищите по тегу "неточный поиск" и "Fuzzy VlookUP". В копилке идей (ветка на форуме) есть такая функция.
Или используйте СцепитьЕсли (см. скрин и файл).

И подумайте, что делать, если под ваше условие попадает несколько позиций (какую-то выводить или все через разделитель)
1.png (16.77 КБ)
Изменено: Jack Famous - 20 Мар 2018 15:22:19
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
 
формула массива
=ВПР(B2&"*";ЕСЛИ(МИН(ЕСЛИ(ДЛСТР(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(B2;A$2:A$10)=1;A$2:A$10);""))>=ДЛСТР(B2);ДЛСТР(A$2:A$10)))=ДЛСТР(A$2:A$10);A$2:A$10);1;)
 
Спасибо работает, до этого я использовал формулу =(ВПР("*"&B2&"*";$A$1:$A$10000;1;0)), но тогда были проблемы когда было несколько похожих чисел.  
 
Jack Famous, интересная функция, спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх