Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование значений заданного количества ячеек
 
Добрый вечер, уважаемые форумчане!

Подскажите пожалуйста в следующем:
Имеем столбец с данными. Необходимо, чтобы диапазон суммирования по данному столбцу можно было менять динамически, т.е. суммируется то количество ячеек (начиная с первой), которому соответствует цифра в определенной "фиксированной" ячейке. Т.е. имеем столбец:
1
3
6
8
9
12
25
30
при вводе в "фиксированную ячейку" цифру 2 должны на выходе получить сумму 1 + 3

при вводе в "фиксированную ячейку" цифр 5 должны на выходе получить сумму 1 + 3 + 6 + 8 + 9

и т.д.

Заранее Вас благодарю!
 
Так ?
Код
=СУММ(СМЕЩ(E8;0;0;I8))
 
Так можно:
=СУММПРОИЗВ((СТРОКА(E8:E15)-7<=I8)*E8:E15)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
=SUM(E7;INDEX(E8:E15;H8))
Бонусом если 0, то все складываем
Изменено: БМВ - 20 Мар 2018 23:07:08
 
=СУММ(E8:ИНДЕКС(E8:E15;I8))
 
vikttur, Thanks for translation :-)
 
... и исправление ошибки (и все это за 36 секунд) :)
 
Спасибо всем огромное!!! Выручили! Боги Экселя!! :)  
 
Гуру, я снова к Вам за помощью. Вчерашние формулы, которые Вы мне писали я применял,  для подсчета значений из книги источника в конечную книгу и таким образом между двумя книгами образовывалась связь. И все шло отлично, до того момента пока я не закрывал книгу источник. После закрытия книги источник в конечной книге, в ячейках появлялись #ССЫЛКА! вместо значений. а после того, как я открывал книгу источник, то значения восстанавливались. Ну и логичный вопрос, как сделать так, чтобы при закрытии книги источника, связь не пропадала и вообще возможно ли это? На сайте https://support.office.com/ru-ru/article/%D0%A3%D0%BF%D1%80%D0%B0%D0%B2%D0%BB%D0%B5%D0%BD%­D0%B8%D0%B... прочитал следующее: Связь с параметрическим запросом нельзя обновить без открытия книги-источника.
Изменено: babayan.r.a - 22 Мар 2018 00:06:28
 
babayan.r.a, попробуйте вместо СУММ() использовать СУММПРОИЗВ()
Алексей М.
 
Попробовал, ничего не получается
 
Проверил предложение АlехМ, У меня работает.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
СУММ() должен работать при вводе как формулу массива.
Алексей М.
 
АlехМ, там же нет массива. Просто область.
 
У меня шпаргалка есть
Функции для закрытых книг
Обычные: ВПР, ИНДЕКС, ПРОСМОТР, ПОИСКПОЗ, СУММПРОИЗВ
Массивные: СУММ, СЧЕТ
Там где в аргументе массив или таблица.
Обычные ссылки типа: =[файл]лист!A1

Не подводила ни разу.
Алексей М.
 
В метро с телефона середину не прочел :-) оказывается книгу закрыли :-)
 
АlехМ, здравствуйте. Т.е. всё зависит от внешней функции, а то что внутри формулы роли не играет?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, Вся формула должна быть составлена из функций, которые могут работать с закрытыми книгами.
Алексей М.
 
Понял. Спасибо.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Я ничего не понял) вот, допустим, я пользуюсь этой формулой =СУММ(СМЕЩ(E8;0;0;I8)), как ее нужно записать, чтобы при закрытой книге источнике связи не пропадали?  
 
Цитата
Bema написал:
=СУММПРОИЗВ((СТРОКА(E8:E15)-7<=I8)*E8:E15)
Вот эту формулу проверил. Работает даже если файл-источник закрыт.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
babayan.r.a, СМЕЩ() не работает с закрытой книгой.
Алексей М.
 
Цитата
Bema написал:
Вот эту формулу проверил. Работает даже если файл-источник закрыт.
Друзья, я наверное тупой, но у меня ничего не получается. Вот две книги, закрываю источник и связи пропадают!
 
формула для F4
=СУММПРОИЗВ((СТРОКА($E$3:$E$33)-2<=F2)*'[Книга исходная.xlsx]Лист1'!$E$3:$E$33)
Откройте Книгу исходную и конечную. Книги в одной папке.
Вставьте формулу в Книгу конечную.
Сохраните файл.
Закройте две книги, откройте конечную.
Изменено: АlехМ - 23 Мар 2018 10:02:10
Алексей М.
 
АlехМ,а книги обязательно в одной папке должны лежать?
 
Не обязательно, но формулу вставляете при открытой исходной книге
Алексей М.
 
АlехМ,Спасибо Вам огромное!!! Все получилось!
Страницы: 1
Читают тему (гостей: 1)
Наверх