Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Дублирование формулы N-раз в последовательные ячейки, повторение одной и той же формулы с последующим суммированием
 
Добрый вечер!
Задача следующая:
Есть числовой ряд (строка 9). Каждое число этого ряда должно быть прибавлено к числу строкой ниже N раз.(см. изображение)

Для первого числа формула получается: ЕСЛИ($C5>=1;$B9*$C4;0), но для последнего уже
=ЕСЛИ($C5>=11;$B9*$C4;0)+ЕСЛИ($C5>=10;$C9*$C4;0)+ЕСЛИ($C5>=9;$D9*$C4;0)+ЕСЛИ($C5>=8;$E9*$C4;0)+ЕСЛИ($C5>=7;$F9*$C4;0)+ЕСЛИ($C5>=6;$G9*$C4;0)+ЕСЛИ($C5>=5;$H9*$C4;0)+ЕСЛИ($C5>=4;$I9*$C4;0)+ЕСЛИ($C5>=3;$J9*$C4;0)+ЕСЛИ($C5>=2;$K9*$C4;0)+ЕСЛИ($C5>=1;$L9*$C4;0  и т.д

Есть ли какой-либо способ упростить эту формулу?
 
n=3
Что это значит? Добавить только в трех ячейках? Но у Вас весь ряд выведен... Уточните
 
N - это количество раз, при котором значение ячейки сохраняется в сумме, т.е. если скажем N=5, то во второй строке значение должно продублироваться 5 раз. Поэтому сейчас используется формула ЕСЛИ($C5>=5;24;0), т.е если N>=5, то ячейка в сумме участвует, если меньше, то нет.
 
Формула массива. Вводить темя клавишами Ctrl+Shift+Enter
=СУММ(ЕСЛИ($C$5>=СТОЛБЕЦ()-СТОЛБЕЦ($C$10:C10)+1;$B$9:B9)*$C$4)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Вводится как не массивная, в ячейку С10. Возможно есть что то лишнее.
Код
=ОКРВНИЗ(СУММПРОИЗВ((ИНДЕКС($B$9:B9;ЕСЛИ(СЧЁТ($B$9:B9)<=$C$5;1;1+СЧЁТ($B$9:B9)-$C$5)):B9)*$C$4);1)
Страницы: 1
Читают тему (гостей: 1)