Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет количества значений в колонке при 4 условиях, Использую формулу =СУММЕСЛИМН, однако она неправильно работает
 
Добрый вечер, уважаемые форумчане.
Очень прошу у Вас помощи исправить формулу, или возможно заменить на такую, что будет верно подсчитывать количество
значений при 4 условиях.
На листе "Rep" в колонках:
А2:A - даты;
С2:С - номера составов авто;
Q2:Q - номера товаров в авто (их только 4: 1-бакалея,2-напои,3 -химия, 4 - другое)
R1:R - есть ли в авто свободное место (1 - есть, - нет)

На листе "Отчет" в D4:M5 нужно формулой вычислить сколько таких cвободных мест с колонки  R1:R  листа "Rep",
с принадлежностью к составам авто в С4:С5 листа "Отчет", даты в D1 или J1 листа "Отчет" и номера товаров в авто D3:M3 листа "Отчет"
Для этого я использую формулу для например ячейки D4
Код
=СУММЕСЛИМН(Rep!$Q$2:$Q$54;Rep!$Q$2:$Q$54;D3;Rep!$A$2:$A$54;$D$1;Rep!$C$2:$C$54;$C4;Rep!$R$2:$R$54;1)
Для D4 данная формула отлично работает, но для всех последующих ячеек она считает неверно.
Помогите пожалуйста улучшить формулу, чтобы она правильно считала. Заранее спасибо.
 
Проверяйте:
=СЧЁТЕСЛИМН(Rep!$A$2:$A$54;Отчет!$D$1;Rep!$C$2:$C$54;Отчет!$C4;Rep!$Q$2:$Q$54;Отчет!D$3;Rep!$R$2:$R$54;"<>"&"-")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Здравствуйте. Думаю если использовать вместо СУММЕСЛИМН(), СЧЁТЕСЛИМН() то будет правильнее.
Код
=СЧЁТЕСЛИМН(Rep!$Q$2:$Q$54;D$3;Rep!$A$2:$A$54;$D$1;Rep!$C$2:$C$54;$C4;Rep!$R$2:$R$54;1)
 
Bema и gling Огромное Вам сипасибо. Супер.
 
Можно и с помощью СУММЕСЛИМН:
=СУММЕСЛИМН(Rep!$R$2:$R$54;Rep!$A$2:$A$54;Отчет!$D$1;Rep!$C$2:$C$54;Отчет!$C4;Rep!$Q$2:$Q$54;Отчет!D$3)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх