Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Распределение временного промежутка указанного в одной ячейке по часовому периоду в таблице
 
Всем доброго времени суток. Столкнулся с проблемой, даже затрудняюсь ее описать.
В ячейке указано время работы в формате 08:00-16:00.
Есть сетка времени с 00 до 24.
Как с помощью формул заставить заставить любимый эксель заполнять сетку времени основываясь на ячейке с временем.
В примере наглядно есть что нужно )
 
в D3 и растянуть вправо
Код
=ЕСЛИ(И(ЧАС(--ЛЕВБ($B$2;5))<=D2;ЧАС(--ПРАВБ($B$2;5))>D2);1;"")
Лень двигатель прогресса, доказано!!!
 
Сергей, почему может не работать если время 12:00-24:00
 
потому что 24:00 для экселя = 0, в связи с чем второе условие всегда ложь, смотрите в файле
Код
=ЕСЛИ(И(ЧАС(--ЛЕВБ($B3;5))<=D$2;ЕСЛИ(ЧАС(--ПРАВБ($B3;5));ЧАС(--ПРАВБ($B3;5));25)>D$2);1;"")
Лень двигатель прогресса, доказано!!!
 
Сергей, Спасибо за разъяснения ! И за помощь в формуле !
 
Сергей,  добрый день! Вынужден задать еще вопрос Вам и побеспокоить как следствие ))
А если рабочее время с 16:00 до 04:00, т.е. с переходом в сутках, это как то можно указывать или нет ?
Заранее благодарю Вас.
 
если опираться не только на время но и на даты то можно
Лень двигатель прогресса, доказано!!!
 
Сергей, В примере который вы скидывали можете показать ? пожалуйста.
 
покажите свой что вы там химичите
Лень двигатель прогресса, доказано!!!
 
Сергей, только не осуждайте дилетанта. лист основа.
 
ток глянул вопрос как вы представляете отображение 15:00-03:00 на выбранную дату должен отразится только участок с 15 часов до 23 или как
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
с 15 часов до 23
да
 
kentouklad, смотрите в файле лишнее можете убрать если переход на другие сутки не нужен
Лень двигатель прогресса, доказано!!!
 
Все огонь. Спасибо! Немного поломал голову, не все сразу заработало когда формулы перенес в основной файл, там формат ячеек с часами нужно было изменить! Еще раз спасибо, Вы очень помогли. Хороших Вам выходных!
Страницы: 1
Читают тему (гостей: 1)
Наверх