Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Перенос данных из одной таблицы в другую по условию.
 
Добрый день!

Помогите пожалуйста решить задачу.
Есть две одинаковых таблицы, одна исходная, вторая заполняется данными из первой.
Позиция из первой таблицы появляется во второй при условии, что ее количество больше нуля.
В итоге во второй таблице должно быть тоже что и в первой за исключением тех позиций, количество которых 0.
Для примера изобразил в файле желаемый результат.

Спасибо!
 
Norton Virt, а повторения в 1 столбце бывают?! если нет- то по-быстрому  в ячейку F2
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$20;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(F$1:F1;$A$2:$A$20)=0)/($B$2:$B$20<>0);0);0));"")
в ячейку G2
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$B$20;ПОИСКПОЗ($F2;$A$2:$A$20;0);2);"")
Изменено: a.i.mershik - 22 Мар 2018 16:53:05
 
Все значения уникальны.
Повторов нет.
Изменено: Norton Virt - 22 Мар 2018 16:54:42
 
еще вариант формулой массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$B$20;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$20<>0;СТРОКА($B$2:$B$20));ЧСТРОК($F$2:$F2));ПОИСКПОЗ(F$1;$A$1:$B$1;0));"")
 
Как вариант - расширенный фильтр.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
a.i.mershik, Спасибо!
MOTO, Спасибо!
Z, Спасибо!  
Страницы: 1
Читают тему (гостей: 1)
Наверх