Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет количества непустых значений по условию
 
Задачка вроде и простая, но не могу спарить ГПР и СЧЁТЕСЛИ. Есть перечень номенклатур, есть таблица, в которой фиксируются признаки номенклатуры. Нужно посчитать, сколько признаков имеет каждая номенклатура. Пример во вложении. В столбце "Количество сортов (формула)" нужно с помощью формулы посчитать количество сортов каждого фрукта. Проверочное значение вручную вписано в столбце "Количество сортов (вручную)".
 
вариант
Код
=СЧЁТЕСЛИ(ИНДЕКС($F$2:$H$4;;ПОИСКПОЗ(B3;$F$1:$H$1;0));"<>")
Лень двигатель прогресса, доказано!!!
 
Сергей,Спасибо!
 

собственно и если не нужно =COUNTA(INDEX($F$2:$H$4;0;MATCH(B3;$F$1:$H$1;0)))

 
Еще вариант
Код
=СУММПРОИЗВ(($F$1:$H$1=B3)*($F$2:$H$4<>""))
Страницы: 1
Читают тему (гостей: 1)