Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Просуммировать данные Столбца Матрицы по данным строки другой матрицы, Есть Матрица с большим количеством столбцов. Необходимо просуммировать данные столбцов и разместить результат построчно (по критерию)
 
Доброго времени суток!!!

Есть Таблица с большим количеством столбцов (и строк). Необходимо просуммировать данные столбцов и разместить результат построчно (по критерию) в другую Таблицу.
Вложен файл для примера.

Заранее благодарна, Анастасия
 

Названеи темы более запутано чем решение. Предложите что-то более вразумитьлное.

=SUMIF($C$3:$C$7;C$12;INDEX($E$3:$G$7;;MATCH($B13;$E$2:$G$2))) и

=SUMIFS(INDEX($E$3:$G$7;;MATCH($B13;$E$2:$G$2));$C$3:$C$7;$C$12;$D$3:$D$7;D$12)

или чтоб блок месяцев не корректировать

=SUMIFS(INDEX($E$3:$G$7;;MATCH($B13;$E$2:$G$2));$C$3:$C$7;LOOKUP(2;1/ISNUMBER($C$12:D$12);$C$12:D$12);$D$3:$D$7;D$18)
 
Варианты в файле.
Код
=СУММПРОИЗВ(($E$2:$G$2=$B13)*($D$3:$D$7=D$12)*($C$3:$C$7=D$11)*$E$3:$G$7)
Изменено: gling - 24 Мар 2018 09:17:39
 
gling, один коммент,
Цитата
Zergel написал:
большим количеством столбцов (и строк).
в данном случае SUMIF(S) буду предпочтительнее, по скорости, а также позволят работать целиком со столбцом, так как работают с заполненной областью.

P.S. Если итоговая таблица тоже большой размерности, то несколько сервисных вычислений лучше иметь в отдельном столбце/ строке
 
Изменено: БМВ - 24 Мар 2018 09:19:00
 
Большое большое благодарю!!!!

Формула Суммпроизв просто РУЛИТ!!!
 
=SUMIFS(INDEX($E$3:$G$7;;MATCH($B25;$E$2:$G$2));$C$3:$C$7;LOOKUP(2;1/ISNUMBER($C$24:C$24);$C$24:C$24);$D$3:$D$7;IF(C$24=LOOKUP(2;1/ISNUMBER($C$30:C$30);$C$24:C$24);"*";C$30)
одна для года и месяца
Изменено: БМВ - 24 Мар 2018 09:32:24
 
Цитата
Zergel написал:
с большим количеством столбцов
Всё относительно. Если мы платим, то миллион это много, а если получаем, то миллион мало.)))
За 10 лет 120 столбцов думаю это не много. Но если будет тормозить, ТС сможет использовать СУММЕСЛИ(). Я же не написал что это конечное решение, это Вариант.
 
gling, я конечно больше про строки. даже предельное количество столбцов не так страшит :-) 1 048 576 строк и 16 384 столбца
Страницы: 1
Читают тему (гостей: 1)
Наверх