Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Если число изменяется на определенное значение, то изменять значение ячейки
 
Привет! Подскажите пожалуйста формулу или решение такой задачи:

Есть число в ячейке B2. Если это число от 0 до 250 000, то ячейка C2 = 30. Если это число от 250 000 до 400 000, то ячейка C2 = 40. Если это число от 400 000 до 600 000, то ячейка C2 = 45. Если это число от 600 000 до 800 000, то ячейка C2 = 50.

Если же число в ячейке B2 больше 800 000, то за каждые 50 000 нужно прибавлять в ячейку C2 +10.
------
Кажется, я понял, как разобраться с первой частью. Получилось так:  =ЕСЛИ(И(B2>=0;B2<250000);30);ЕСЛИ(И(B2=>250000;B2<=400000);40);ЕСЛИ(И(B2=>400000;B2<600000);45);ЕСЛИ(И(B2=>600000;B2<800000);50);

Но не понимаю, как решить вторую часть. Уже голову сломал.
 
Здравствуйте. Вариант
Код
=ПРОСМОТР(B2;{0:250001:400001:600001};{30:40:45:50})+ЦЕЛОЕ((B2-800000)/50000)*10*(B2>800000)
 
Спасибо! Все получилось!)
 
gling, а не просто 250000:400000:600000?
 
Цитата
БМВ написал:
а не просто 250000:400000:600000?
Смотря как считать  "ДО", включительно или исключительно. У меня "ДО" включительно, но ноль вначале всё равно должен быть.
 
я не про ноль, с ним все ок, но  по условию И(B2>=0;B2<250000), то есть исключительно.
 
=CHOOSE(LOOKUP(B2;{0;250000;400000;600000;800000};{1;2;3;4;5});30;40;45;50;50+INT((B2-800000)/50000)*10)
 
В задании действительно исключительно.
БМВ, спасибо, что обратили внимание. Я вот проглядел.
Все работает)
 
Цитата
БМВ написал:
то есть исключительно.
Точно, а я на это условие внимание не обратил, по описанию стряпал.
Страницы: 1
Читают тему (гостей: 1)