Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск недостающих элементов в списке, найти недостающий элемент в писке
 
Есть список от 1 до 25. Но при выборе выбирается допустим 5 элементов. Список принимает вид, примерно как 1,2,3,5,7,8,9 и т.д.. Как формулой найти недостающий элемент 4, 6 и т.д.
 
Если правильно понял. Список недостающих фамилий в табличке A1:E5
Формула массива
=ИНДЕКС(фамилии;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(A$1:E$5;фамилии)=0;F$1:F$25);СТРОКА(A1)))
Можно добавить функцию ЕСЛИОШИБКА()
Изменено: АlехМ - 26 Мар 2018 11:48:30
Алексей М.
 
tereha, вариант №2
 
работает, но в А1:Е5 выбранные фамилии, а недостающие Р7:Р25 (красным отмечены.


Но все работает, спасибо огромное
 
в примере работает, а в моем проэкте нет((((
 
смысл, что в О1:О25 выбранные фамилии, а в Р1:Р25 должны оказаться остальные которые не выбраны  
 
В L6:L25 должны оказаться цифры, от 1до 25 кроме L1:L5
 
Цитата
tereha написал:
именно так
Цитата
tereha написал:
в примере работает, а в моем проэкте нет((((
Вы кому пишите?
Алексей М.
 
Алексей, Вам)))
 
Цитата
АlехМ написал:
Формула массива
Формулы массива вводятся тремя клавишами Ctrl+Shift+Enter
При правильном вводе формула обрамляется фигурными скобками так
{=формула}
Изменено: АlехМ - 26 Мар 2018 12:32:39
Алексей М.
 
я знаю, просто я в примере простенько показал, а в проэкте немножко по-другому, ну да ладно, я сейчас попроще переделаю.
 
есть числа в столбце (В1:В25) от 1 до 25.
В столбце D1:D5 выбранные числа (3,7,11,17,23)
Как в столбец Е6:Е25 вывести числа, которых не хватает (1,2,4,5,6,8,9,10,12,13,14,15,16,18,19,20,21,22,24,25)
 
Так нужно?
Алексей М.
 
Цитата
АlехМ написал:
Так нужно?
да.

К такой формуле я бы точно не додумался.

огромное Вам спасибо Алексей.
 
Ну, можно же сначала подумать, потом написать? Зачем Вы создаете очереди из сообщений? Мысль не успела за руками - вернитесь, дополните предыдущее сообщение.
Страницы: 1
Читают тему (гостей: 1)