Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск по массиву выдает ошибку, когда в одной из ячеек избыток текстовой информации
 
Здравствуйте! Нужен совет!
Ищу по массиву определенные данные по формуле
=ИНДЕКС('Перечень услуг'!O:O;ПОИСКПОЗ(Лист1!A1&Лист1!B24;'Перечень услуг'!A:A&'Перечень услуг'!L:L;0))
=ИНДЕКС('Перечень услуг'!O:O;ПОИСКПОЗ(Лист1!A1&Лист1!B25;'Перечень услуг'!A:A&'Перечень услуг'!L:L;0))
и так далее...

Все хорошо ищет и выведет, НО по одной позиции выводит #ЗНАЧ!.
Начал разбираться оказывается, пишет неправильный тип данных.
В этом диапазоне "Перечень услуг'!L:L" есть ячейка с которой как раз и сравниваю ячейку В25 (к примеру).
В этой ячейки стоит формат ячейки "Общий" а в образце повторяющийся символ "#".
Как я понял что текстовой информации в этой ячейке слишком много поэтому и происходит такая ошибка.

Думаю поставить условие, к примеру информация находилась по части определенного текста, но к сожалению не понимаю как.
Подскажите как правильно решить данную проблему!
 
Timett, а прикрепите пример того что есть и что получается и что хотите.
 
формат ячейки не влияет на формулу.
 
К сожалению документ более 100 kb, залил на сервис
http://dropmefiles.com/SGgcC

Лист1 ячейка H23
 
Timett,  это ?!
Код
=ПРОСМОТР(2;1/(Лист1!B23='Перечень услуг'!L:L)*(Лист1!$A$1='Перечень услуг'!A:A);'Перечень услуг'!O:O)
 
Большое Спасибо! Хорошее у вас сообщество, очень оперативно!
Не объясните в чем могла быть проблема?
Или данная формула, которую я использую имеет какие то ограничения?  
 
Вопрос остался открытым!
К сожалению данная функция не подхватывает другие значения, а остается просто статической.

Ссылка на файлhttp://dropmefiles.com/mjUdm

Лист1!H23

Подскажите как решить проблему!
 
а приложить пример только касаемо вашей проблемы не можете зачем там столько лишней информации
Цитата
Timett написал:
К сожалению данная функция не подхватывает другие значения
какие другие значени
Лень двигатель прогресса, доказано!!!
 
При изменении значения в Лист1!A1 в ячейке H23 должна обновиться информация согласно таблице Перечень услуг, столбца O.
А данная формула подхватила один раз значение и больше не изменяет его.
Лист1!A1 имеет только пока 2 значения 1 и 2, добавление происходит в таблице Реестр
Изменено: Timett - 3 Апр 2018 14:41:13
 
какое вы значение выбираете что вы видите ошибку я выбираю любое значение имеющееся на листе перечень услуг и все меняется, у вас автопересчет формул включен (вкладка формулы => параметры вычислений)
Лень двигатель прогресса, доказано!!!
 
вкладка формулы => параметры вычислений включено Автоматически

Лист1!A1 ставим значение 1, то  в H23 должно быть значение 11, а оно стоит 17 и не изменаеться
Лист1!A1 ставим значение 2, то  в H23 должно как раз быть 17

Я когда применял эту формулу в ячеке A1 была "2" и она запомнила значение 17
Изменено: Timett - 3 Апр 2018 14:47:25
 
в формулеa.i.mershik, часть формулы возьмите в скобки т.е. 1/((Лист1!B23='Перечень услуг'!L:L)*(Лист1!$A$1='Перечень услуг'!A:A))
Лень двигатель прогресса, доказано!!!
 
Timett, в формуле
Код
=ПРОСМОТР(2;1/(Лист1!B23='Перечень услуг'!L:L)*(Лист1!$A$1='Перечень услуг'!A:A);'Перечень услуг'!O:O)
нехватает скобок просто должно быть вот так
Код
=ПРОСМОТР(2;1/((B23='Перечень услуг'!$L:$L)*(Лист1!$A$1='Перечень услуг'!$A:$A));'Перечень услуг'!$O:$O)
 
Примите мою искреннюю благодарность!
Страницы: 1
Читают тему (гостей: 1)