Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Ограничение на выбор значения из списка
 
Добрый день!
Пересмотрел форум и гугл, подходящего решения не нашел.
Помогите пожалуйста подобрать решение данной ситуации:

В столбце А Выбор из 2х значений "Учтено" "Не учтено". необходимо реализовать так, чтобы пока не заполнены столбцы "Причина 1" "Причина 2" "Причина 3" невозможно было выбрать значение "Учтено" (т.е. доступно только "Не учтено").
При этом если заполнено хотя бы одна из ячеек "Причина" то можно выбрать 2 значения.

В ячейках "Причина" ставится значение 1. Т.е. фактически нужно условие, что сумма в "Причинах" >=1, тогда 2 значения, иначе одно.

Помогите пожалуйста решить проблему.
Спасибо!
 
noxik, в проверку данных вместо ссылки на диапозон
Код
=ЕСЛИ(СЧЁТ(B2:D2)<1;Список!$A$2;Список!$A$1:$A$2)
Изменено: a.i.mershik - 26 Мар 2018 14:22:21
 
a.i.mershik,
Спасибо большое!
Если хочу добавить больше ограничений, то просто меняю из справочника диапазон?  
 
noxik, в смысле больше ограничений?
 
a.i.mershik,
Допустим чтобы выводилось не только "Не учтено", а еще несколько вариантов
 
noxik, ну наверное добавить в список и диапазон увеличить...
 
a.i.mershik,Это и имел ввиду, спасибо!
Страницы: 1
Читают тему (гостей: 1)