Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
как выбрать из текста сумму без начальных и конечных слов и без переводов строк, очистка текста от примесей слов
 
Здравствуйте как сократить формулу, слишком большая вышла
=СЖПРОБЕЛЫ(ПЕЧСИМВ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ВПР("*"&$B2&"*";Отчет!$B:$H;5;ЛОЖЬ);ЕСЛИОШИБКА(ПРАВСИМВ(ВПР("*"&$B2&"*";Отчет!$B:$H;5;ЛОЖЬ);ПОИСК("р.";ВПР("*"&$B2&"*";Отчет!$B:$H;5;ЛОЖЬ))+1);"");"");"сп ";"")))

при формуле =ВПР("*"&$B2&"*";Отчет!$B:$H;5;ЛОЖЬ)
выходит такое
сп 25 467,46р. гп   482,01 р.
   
сп 21 317,52р. гп 419,76 р.
5   634,91р. 200,00р.
   
15 175,50р. гп 303,51 р.
   
как удалить "сп ", и все что после первого р.
должно выйти так без переводов строк
25   467,46р.
21   317,52р.
5   634,91р.
15 175,50р.
Изменено: Goldenito - 28 Мар 2018 05:39:02
 
такой вариант
Код
=ПОДСТАВИТЬ(ЛЕВБ(C2;ПОИСК(".";C2));"сп ";"")
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
такой вариант
е смог я ее применить
 
что не смогли не понятно вместо ссылки на ячейку свой ВПР вставить, в С1 на листе Поиск и протянуть вниз
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(ЛЕВБ(ВПР("*"&$B1&"*";Отчет!$B:$D;2;0);ПОИСК(".";ВПР("*"&$B1&"*";Отчет!$B:$D;2;0)));"сп ";"");)
Лень двигатель прогресса, доказано!!!
 
Сергей, спасибо очень помогло, отличное решение
Страницы: 1
Читают тему (гостей: 1)
Наверх