Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как разбить число одной ячейки во множество других Excel ?, Как разбить число одной ячейки во множество других Excel ?
 
Доброе утро Друзья!
Столкнулся с жуткой проблемой.
У меня есть файл во вкладке № 1, там есть 4 уникальных значения в котором прописаны MOQ (минимальное значение в кол-ве)
Вопрос:
Как мне сделать так чтобы через функцию "ВПР" подтянуть значение в столбце "MOQ" из вкладки "№1" в вкладку "№2" с разделением кол-ва MOQ в произвольном или ровном количестве на позиции задублированные в вкладке "№ 2" (пример вложил).
 
самый простой вариант так
Код
=ВПР(A2;'№ 1'!$A$2:$C$5;3;0)/СЧЁТЕСЛИ($A$2:$A$37;A2)
Лень двигатель прогресса, доказано!!!
 
В С2
Код
=ВПР(B2;'№ 1'!$B$2:$C$5;2;0)/СЧЁТЕСЛИ($B$2:$B$37;B2)
 
Друзья спасибо Вам большое.
Две формулы работают без наркеканий, но появились и подводные камни.
Но позиция "0402-NPO-50В-0,01 мкФ 10% чип конденсатор 2238-587-15636 PHY" разделилась на кол-во 833,3333333.
Мне нужны целые числа................
 
=INT(VLOOKUP(A2;'№ 1'!A:C;3;0)/COUNTIF(A:A;'№ 2'!A2))+(MOD(VLOOKUP(A2;'№ 1'!A:C;3;0);COUNTIF(A:A;'№ 2'!A2))>=COUNTIF($A$1:$A2;A2))*(COUNTIF($A$1:$A2;A2)>0)

остаток равномерно распределяется в порядке от первого до того, кому хватит

вы немного сами запутали ребят, форматированием. Количество, как правило не оформляется с дробной частью.
Изменено: БМВ - 28 Мар 2018 10:22:17
 
Цитата
Сергей написал:
Код ? 1=ВПР(A2;'№ 1'!$A$2:$C$5;3;0)/СЧЁТЕСЛИ($A$2:$A$37;A2)
Спасибо Вам большое.
Две формулы работают без наркеканий, но появились и подводные камни.
Но позиция "0402-NPO-50В-0,01 мкФ 10% чип конденсатор 2238-587-15636 PHY" разделилась на кол-во 833,3333333.
Мне нужны целые числа................
 
Цитата
БМВ написал:
=INT(VLOOKUP(A2;'№ 1'!A:C;3;0)/COUNTIF(A:A;'№ 2'!A2))+(MOD(VLOOKUP(A2;'№ 1'!A:C;3;0);COUNTIF(A:A;'№ 2'!A2))>=COUNTIF($A$1:$A2;A2))*(COUNTIF($A$1:$A2;A2)>0)остаток равномерно распределяется в порядке от первого до того, кому хватитвы немного сами запутали ребят, форматированием. Количество, как правило не оформляется с дробной частью.
СПАСИБО ВАМ ОГРОМНОЕ - СПАСИБО ВСЕМ.

Прошу прощения если кого запутал -сделал ненамеренно.
Страницы: 1
Читают тему (гостей: 1)
Наверх