Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет количество строк по условиям -статус - дата-время
 
Подскажите формулу для подсчета количества строк с определенными условиями:
Данные,
Ячейка А1 - дата
Ячейка В1 - время
Ячейка С1 - статус (открыта, закрыта)

Необходимо что бы считал только те строки, которые бы соответствовали одновременно следующим условиям:
1) Статус - закрыта
2) Дата и время начинаются со Вчерашнего дня 10:15 и по Сегодняшний день 10:15
Изменено: Ackord - 28 Мар 2018 11:07:21
 
Цитата
Ackord написал: для подсчета количества строк
Вариант -  =СЧЕТЕСЛИМН() ... ;)
ps F1 - подсказка при открытии функции.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
По статусам я вопрос решил, про даты смог написать вот такую формулу, она считает строки за вчера и сегодня, но не могу составить условие, что бы считало с 10:15 вчера по 10:15 сегодня.

=СЧЁТЕСЛИМН(С2:C100;"закрыта"; А2:А1000; СЕГОДНЯ()-1) + СЧЁТЕСЛИ(А2:А1000; СЕГОДНЯ())  
 
Цитата
Ackord написал: но не могу составить условие
Правила пп 2.2, 2.3.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
правильный результат какой должен быть 4?, если да то так можно
Код
=СУММПРОИЗВ((A2:A9+B2:B9>=СЕГОДНЯ()-1+ВРЕМЯ(10;15;))*(A2:A9+B2:B9<=СЕГОДНЯ()+ВРЕМЯ(10;15;))*($C$2:$C$9="закрыта"))
Лень двигатель прогресса, доказано!!!
 
Спасибо! Все работает!
Изменено: Ackord - 28 Мар 2018 14:45:26
Страницы: 1
Читают тему (гостей: 1)