Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Обработка данных введенных через слэш
 
Здравствуйте. Помогите, пожалуйста,с такой проблемой. Есть формула которая подставляет данные в зависимости от значения в ячейке А1. Все нормально работает, но нужно в ячейке ввести числа через слэш, то есть такого вида 100/724, а результат в идеале нужен: Первый/Третий. Можно это как-то реализовать?
 
vladqw, если создать таблицу число - текст
Код
=ЕСЛИОШИБКА(ВПР(A1;$A$5:$B$7;2);ВПР(--ЛЕВБ(A1;НАЙТИ("/";A1)-1);$A$5:$B$7;2)&"/"&ВПР(--ПСТР(A1;НАЙТИ("/";A1)+1;9);$A$5:$B$7;2))
 
Цитата
vladqw написал:
а результат в идеале нужен: Первый/Третий.

:qstn: Чего? :qstn:  :excl:  :excl:  
 
Добрый день!
Так?
 
Казанский, Arturus, Огромное спасибо за помощь!
Страницы: 1
Читают тему (гостей: 1)