Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Можно ли производить вычисления с датами в текстовом формате ("12 октября")?
 
В файле Пример.xlsx необходимо определить с помощью формулы массива количество значений в период с 3 октября по 7 октября.
Созданная мной формула {=СЧЁТ(ЕСЛИ(A2:A20>="3 октября";ЕСЛИ(A2:A20<="7 октября";1)))} считает количество значений от 7 октября и до 1 октября.
Где ошибка?
 
можно
делаем доп столбец?
Лень двигатель прогресса, доказано!!!
 
У Вас нет дат. Текст нужно преобразовывать в даты:
=СУММПРОИЗВ(--(--ПОДСТАВИТЬ(ЛЕВБ(A2:A20;6);"ая";"ай")>=--"03.10");--(--ПОДСТАВИТЬ(ЛЕВБ(A2:A20;6);"ая";"ай")<=--"07.10");B2:B20)
 
vikttur,  Если в пределах предлооженных данных, то простое сравнение даст результат,
но появление например ноября - все разрушит ибо 2 ноября будет стоять после 1 октября и перед  2 октября а не после 30 октября.

Bvlad05, =SUMPRODUCT((A2:A20>=A6)*(A2:A20<=A14)) ну или с массивным вводом =SUM((A2:A20>=A6)*(A2:A20<=A14))
a6 b a14 граничные даты, просто лень было набирать.
Изменено: БМВ - 28 Мар 2018 13:03:01
 
Коллеги спасибо за рекомендации. Однако моя конструкция странным образом заработала. Я понимаю, что она работает только в пределах представленных данных.  
Страницы: 1
Читают тему (гостей: 1)
Наверх