Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Получить данные из заголовка таблицы
 
Добрый день. Есть необходимость сделать следующее:

Таблица. В ней около 1000 строк.

Нужно получить столбец с данными из заголовка таблицы. Искомый столбец заполняется по следующему принципу:

Если в строке после ячейки с данными идет пустая ячейка, то из шапки этого столбца берем данные.  

Подскажите, как это можно реализовать ?

upd: Добавил файл .xlsx с шаблоном таблицы.
target.png (15.54 КБ)
Изменено: Protogonist - 28 Мар 2018 17:25:45
 
Protogonist, ну так вот на картинке
а вообще думаю обычный ИНДЕКС+ПОИСКПОЗ...в помощь. Но без файла на картинке не получится.
Изменено: a.i.mershik - 28 Мар 2018 17:16:29
 
a.i.mershik, файл прикрепил )
Изменено: Protogonist - 28 Мар 2018 17:41:58
 
Protogonist, формула массива

МОЖНО ТАК ЕСЛИ ДОБАВИТЬ (ЧТО БЫ 0 НЕ ПОКАЗЫВАЛСЯ А ПУСТО БЫЛО)
Код
=ЕСЛИ(ИНДЕКС($A$1:$H$1;1;МИН(ЕСЛИ(A2:H2="";СТОЛБЕЦ(A2:H2))))="";"";ИНДЕКС($A$1:$H$1;1;МИН(ЕСЛИ(A2:H2="";СТОЛБЕЦ(A2:H2)))))
Изменено: a.i.mershik - 28 Мар 2018 17:50:13
 
Еще вариант.Формула массива. Вводить тремя клавишами Ctrl+Shift+Enter.
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$H$1;ПОИСКПОЗ(1=1;ЕПУСТО(B2:H2);0));"-")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)